Styling RadPanelBarItem (mouseover and selcted error)

4 posts, 0 answers
  1. Felix De Lille
    Felix De Lille avatar
    18 posts
    Member since:
    Jun 2009

    Posted 17 Feb 2010 Link to this post

    If i want to style an RadPanelBarItem in blend 3 (i go to "edit template" , edit a copy).

    Then i see all the states. I click on mouseover or selected state and i get the xamlparseexception error (see image).
    In the message there are keywords like xcpImports.checkHRResult and storyboardseekalignedtolasttick.

    Please someone help me. I just want to style the headers of the items.

    Greetings
  2. Dimitrina
    Admin
    Dimitrina avatar
    442 posts

    Posted 19 Feb 2010 Link to this post

    Hi Felix De Lille,

    Thank you for your feedback. We are really sorry for the inconvenience caused. Please find attached a project with fixed control template of the RadPanelBarItem.

    Your Telerik points have been updated.

    Greetings,
    Dimitrina
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. DevCraft banner
  4. Felix De Lille
    Felix De Lille avatar
    18 posts
    Member since:
    Jun 2009

    Posted 19 Feb 2010 Link to this post

    Thanks,

    Your project works to style the panelbaritem.
    How do i update my toolbox panelbaritem so its fixed? I tried copy the panelbaritem from your project to mine but i still get the error when then templating it.

    Also another problem i encountered is that if you have multiple panelbaritems in the panelbar you want to give different style per item. It's impossible.. The templates use the same resources somewhere (even dough some squares are not green).

    Greetings
  5. Tihomir Petkov
    Admin
    Tihomir Petkov avatar
    576 posts

    Posted 23 Feb 2010 Link to this post

    Hi Felix,

    Unfortunately, when you drag a control from the toolbox you will always get the default ones and thus you will have to manually assign the custom style from the previous post. This will be fixed once we release a new version of the controls and you install them.

    Regarding your second question, please refer to my answer to a similar question you asked on the following thread:
    http://www.telerik.com/community/forums/silverlight/panelbar/different-styles-in-same-itemcollection.aspx

    Regards,
    Tihomir Petkov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Back to Top