Strange bug

7 posts, 0 answers
  1. Oleg
    Oleg avatar
    42 posts
    Member since:
    Oct 2011

    Posted 21 Sep 2012 Link to this post

    Hey there,

    I have a strange thing on my ScheduleView. It cant be reproduces everytime, but it appears very often.
    And it has something to do with switching betweet day/week/month views. 

    You can see the bug on attached screenshot. A possible way to reproduce is "Go to month view -> Go to week view -> Again back to month view".

    If you click on the strange stretched field - you will land in the week view.

    Any ideas what that is?

    Edit: I cant find any "upload file" option. So I uploaded it to this website:
    http://s14.directupload.net/file/d/3020/ypumowpi_png.htm
  2. Vladi
    Admin
    Vladi avatar
    744 posts

    Posted 25 Sep 2012 Link to this post

    Hello Oleg,

    We tried to reproduce the issue at our side but with no success.

    Could you try to reproduce the issue in our online demos here and describe to us the steps needed to reproduce it?

    Kind regards,
    Vladi
    the Telerik team

    Time to cast your vote for Telerik! Tell DevPro Connections and Windows IT Pro why Telerik is your choice. Telerik is nominated in a total of 25 categories.

  3. DevCraft banner
  4. Oleg
    Oleg avatar
    42 posts
    Member since:
    Oct 2011

    Posted 04 Mar 2013 Link to this post

    Hey there again!

    Becouse the bug is still there, i need some help to identify the source of it.
    Can you please tell me, what is the name of the control/template/style of the marked items on the screenshot? These month navigation bars on the left? It seems as if the "4 Feb - 10 Feb" item has wrong ZIndex and Stretch mode...

    Thx!
  5. Oleg
    Oleg avatar
    42 posts
    Member since:
    Oct 2011

    Posted 08 Mar 2013 Link to this post

    Telerik, could you find anything? Or just tell me how this template part is called?
  6. Vladi
    Admin
    Vladi avatar
    744 posts

    Posted 12 Mar 2013 Link to this post

    Hello,

    We are not aware of any known issues concerning the GroupHeaders in MonthView.

    Could you try to reproduce the issue in a sample project and sent it to us in a support ticket?

    All the best,
    Vladi
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  7. Oleg
    Oleg avatar
    42 posts
    Member since:
    Oct 2011

    Posted 12 Mar 2013 Link to this post

    Please use the attached files to reproduce my problem (use link for download).
    http://www.megafileupload.com/en/file/401131/TestApp-zip.html


    Start App, click on Week View and then click on the Month View.


    Thx
  8. Vladi
    Admin
    Vladi avatar
    744 posts

    Posted 13 Mar 2013 Link to this post

    Hi Oleg,

    As we see you have posted about this issue in another post with ID: 669586 and we have responded to you in that post could we continue the discussion there. I would also like to post the response here too in order for it to be available for the community:

    It seems that you have made some customizations to the theme of the ScheduleView control which is causing the strange behavior when you change views. In the sample project if you remove the custom theme and replace it with the default theme the issues cannot be observed. I would suggest you to use Implicit Styles and make the necessary customizations without the need of coping the entire ScheduleView theme which is the easiest way of making customizations to the ScheduleView themes.

    Kind regards,
    Vladi
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

Back to Top
DevCraft banner