Strange behaviour when unpinning docked pane

6 posts, 1 answers
  1. Barnes
    Barnes avatar
    17 posts
    Member since:
    May 2012

    Posted 31 May 2012 Link to this post

    I am currently experiencing an issue when dragging a radpane that is docked using the RadDocking control.

    When I first drag the pane from its pinned position, it seems to jump away from the mouse pointer. If I continue to drag the item it moves further away from the mouse until I stop dragging it. The behaviour is perfect if I drag a floating pane.

    The behaviour is the same in my application as it is in the RadControls For Silverlight Demos.

    Is this a known issue and if so is there a workaround?

    Thanks in advance
  2. Georgi
    Admin
    Georgi avatar
    350 posts

    Posted 01 Jun 2012 Link to this post

    Hello Barnes,

    I wasn't able to reproduce the issue. In order to get to the bottom of this can you, please tell us :
    • What browser do you use?
    • What is the version of your Silverlight plugin?
    • Are you using Silverlight 5?
    • What is the version of the controls that you are using?
    • Are you using virtual machine or a remote desktop?

    It will be great if you can record a video demonstrating the issue.

    All the best,
    Georgi
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. DevCraft banner
  4. Barnes
    Barnes avatar
    17 posts
    Member since:
    May 2012

    Posted 01 Jun 2012 Link to this post

    Hello Georgi,

    In answer to your questions:

    I am using IE9
    I am using Silverlight 5
    I am using a trial version of RadControls for Silverlight Q1 2012 SP1
    I am not using a virtual machine or remote desktop

    Unfortunately I won't be able to record a video for you.

    Thanks
  5. Georgi
    Admin
    Georgi avatar
    350 posts

    Posted 04 Jun 2012 Link to this post

    Hi Thomas,

    I am still able to see it. I am attaching a video and a simple project. Can you, please check it out and tell us if we are doing the same thing ?

    Greetings,
    Georgi
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  6. Barnes
    Barnes avatar
    17 posts
    Member since:
    May 2012

    Posted 11 Jun 2012 Link to this post

    Hi Georgi,

    it looks like you are doing the same thing. I have attached a link to a video for you to look at demonstrating the issue. Hopefully it will come out clear enough for you to see, although the frame rate is a bit slow.

    http://dl.dropbox.com/u/79190339/DockingIssue.swf

    Firstly I undock a pane and drag it. You will notice that the further the mouse pointer gets to the bottom-right of the screen the further the pane gets from the cursor. The closer it gets to the top-left of the screen teh closer it gets to the cursor. I then release the pane and then drag it again whereupon the expected behaviour is displayed.

    I hope this helps you to get to the bottom of the issue.
  7. Answer
    Georgi
    Admin
    Georgi avatar
    350 posts

    Posted 13 Jun 2012 Link to this post

    Hi Thomas,

    Thanks to your video I was able to see that you have a little bit zoom on your browser and it seems like this is causing the issue.You can vote and track the progress of fixing it here in our Public Issue Tracking System.
    Your Telerik points have been updated for the report.

    All the best,
    Georgi
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

Back to Top
DevCraft banner