Still Getting Upload Error

6 posts, 0 answers
  1. Idan
    Idan avatar
    76 posts
    Member since:
    Oct 2012

    Posted 18 Apr 2014 Link to this post

    I'm still getting upload error message when trying to upload to itunes connect. The first version uploaded successfully, and only I change was a few Javascript code, didn't use any new plugins, nothing but some minor code changes. 

    How can I know exactly where the problem is?

    Thanks
  2. Idan
    Idan avatar
    76 posts
    Member since:
    Oct 2012

    Posted 18 Apr 2014 in reply to Idan Link to this post

    There is a two plugs icon at the top and there is a message

    "Your last operation to the server -[POST https://app.icenium/api/itmstransporter/upload/xxxxx/xxxxx/big/iOS/Release/app.ipa? ... was not successful. Please check your network and try again in a minute to prevent any data loss"

    *removed my app name

    So what does it mean. Something is wrong when uploading, and it might not be an error from iTunes connect at all.


  3. Idan
    Idan avatar
    76 posts
    Member since:
    Oct 2012

    Posted 18 Apr 2014 in reply to Idan Link to this post

    Update:

    Even with that error I see "Waiting for review" on the itunes connect.

    If it is the same as the previous time, if the upload fail you are sending the older version to itunes connect (not 100% sure about that). In the previous upload, I got the error and and it was still showing  "Waiting for review" after a minute. Then I checked the app, and I saw that it didn't contain the updates, and it was the older version.

    I still don't understand how this update from Telerik to iTunes connect work, but if I got an error, how can iTunes connect shows "Waiting for review" ?
  4. Idan
    Idan avatar
    76 posts
    Member since:
    Oct 2012

    Posted 18 Apr 2014 in reply to Idan Link to this post

    Hi,

    I can verify that the previous update that was getting an error message in the Windows Client was uploaded successfully with the right version to itunes connect.

    This means that the error that I've got shouldn't suppose to be there, because the binary was indeed uploaded. I'm still investigating this, but I want to here from your side so this error can be fix, if it is indeed a bug of some kind.

    thanks in advance.
  5. Iva Koevska
    Admin
    Iva Koevska avatar
    286 posts

    Posted 18 Apr 2014 Link to this post

    Hello Idan,

    We are sorry for the confusion you're experiencing.

    After some of Apple's latest updates to its publishing tools and services, the AppBuilder publishing service to iTunes Connect has become exceptionally slow. You, yourself, have already experienced some issues last week.

    In some cases, this slow down might cause timeouts which are reflected in the error you're seeing. However, although a timeout is identified, the operation actually succeeds and your binary gets uploaded to iTunes Connect.

    In your case, you shouldn't worry about your binary since it seems to be successfully uploaded to iTunes Connect. We will further investigate the issue and come up with the necessary measures to prevent these misleading messages in the future.

    Thank you for your understanding and for reporting this. 

    Regards,
    Iva Koevska
    Telerik
     

    Share what you think about AppBuilder and Telerik Platform with us in our feedback portal, so we can become even better!

     
  6. Idan
    Idan avatar
    76 posts
    Member since:
    Oct 2012

    Posted 18 Apr 2014 in reply to Iva Koevska Link to this post

    Thanks for your answer Iva, I start getting very confused about it. Thanks for your reply and your efforts for solving this issue. (Sorry for so many posts, don't have the option to edit the first).
Back to Top