SPRadList and SPRagGrid - unable to get SP Lists in designer

4 posts, 0 answers
  1. Gregory
    Gregory avatar
    1 posts
    Member since:
    Mar 2013

    Posted 05 Apr 2013 Link to this post

    When I am in the designer for the SPRadListView or SPRadGrid I can not get a listing of the SP Lists in my current site. The data binding to SQL works fine. When I try to expand the SP List display when in the Data Binding area I get an error 'There was an error processing the request'. I am on a Win7 PC using Foundation. My id is a local admin and I am the site owner and creator. Any ideas?
  2. Tsvetoslav
    Admin
    Tsvetoslav avatar
    1823 posts

    Posted 10 Apr 2013 Link to this post

    Hello Gregory,

    Could you try setting your account as the site collection administrator and let us know if that makes any difference.

    Regards, Tsvetoslav
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.

  3. David
    David avatar
    1 posts
    Member since:
    Jun 2012

    Posted 07 May 2013 Link to this post

    I'm having the exact same issue. I am also a site collection administrator. Was this ever resolved?
  4. Tsvetoslav
    Admin
    Tsvetoslav avatar
    1823 posts

    Posted 10 May 2013 Link to this post

    Hello Gregory,

    Could you try setting anonymous authentication for the _vit_bin virtual diretory in IIS for your sharepoint application and see if that makes any difference.

    All the best, Tsvetoslav
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top