Spellchecker URL Error

4 posts, 0 answers
  1. Plawrencejr
    Plawrencejr avatar
    7 posts
    Member since:
    Jul 2007

    Posted 07 Aug 2007 Link to this post

    I am using the Lite version of the editor in MOSS, and I noticed that when you run a spell checker it shows URLs as errors. Is there a way of not having this happen.
  2. Lini
    Admin
    Lini avatar
    2144 posts

    Posted 08 Aug 2007 Link to this post

    Hi,

    Yes, you can instruct the spell checker to ignore URLs by adding a property in the editor's configuration file. Insert the following line along with the other properties:

    <property name="SpellFragmentIgnoreOptions">All</property>

    The configuration file is ConfigFile.xml or ListConfigFile.xml, depending on your scenario and it should be located at \Program Files\Common Files\Microsoft Shared\web server extensions\wpresources\RadEditorSharePoint\4.3.0.0__1f131a624888eeed\RadControls\Editor\

    Kind regards,
    Lini
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center

  3. Plawrencejr
    Plawrencejr avatar
    7 posts
    Member since:
    Jul 2007

    Posted 08 Aug 2007 Link to this post

    Can you tell the spell checker to only check the text of the document and not the html?
  4. Lini
    Admin
    Lini avatar
    2144 posts

    Posted 09 Aug 2007 Link to this post

    Hi,

    Are you using the MOSS spell checker or the built-in RadEditor spell tool? I have attached a screenshot, which shows the two tools. If you are using the RadEditor tool, it should check the text, not the html. The MOSS tool does not support our editor so it checks the content as HTML, not as text.

    To enable the RadEditor spell tool, you need to edit the ToolsFile.xml or ListToolsFile.xml (depending on your scenario) and add the AjaxSpellCheck tool. Here is how your tools file could look like:

    <root> 
      <tools name="EnhancedToolbar" dockable="false" enabled="true">  
        <tool name="AjaxSpellCheck" /> 
        <tool name="Cut" shortcut="CTRL+X" /> 
        <tool name="Copy" shortcut="CTRL+C" /> 
    ... 


    Kind regards,
    Lini
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Back to Top