Spell Check Error in MOSS Editor

6 posts, 0 answers
  1. Phani
    Phani avatar
    21 posts
    Member since:
    May 2007

    Posted 17 Sep 2007 Link to this post


    I am using Full featured RADEditor for MOSS in SharePoint Lists. When I tried to add a new word into custom dictionary thru editor, I am getting Forbidden error.

    For example, I tried to add "Palau" in custom dictionary and I got the following error.

    RADSpell error. Server returned error: 403
    Please see the help for more details: RADSpell 3.x - Configuration -Spellcheck Handler.



    Can you please let me know what needs to be done to resolve this issue?

    Also, I have one more question on Spelling in RADEDitor. It seems RADEditor is not recognizing plurals. For Ex: renovations. It is providing suggestion to change the text. Does radeditor recognize plurals?

  2. Lini
    Lini avatar
    2144 posts

    Posted 20 Sep 2007 Link to this post

    Hello Phani,

    The 403 error means that the custom dictionary file is not accessible. The spell control needs to update this file, but the ASPNET process does not have write rights on the dictionary folder. The folder is located at
    \Program Files\Common Files\Microsoft Shared\web server extensions\wpresources\RadEditorSharePoint\\RadControls\Spell\TDF

    Try giving the NETWORK SERVICE account write permissions for this folder. If that does not work, try giving write permissions to the currently logged in MOSS user (if using windows authentication).

    Sincerely yours,

    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center

  3. sayitfast
    sayitfast avatar
    57 posts
    Member since:
    Oct 2006

    Posted 03 Dec 2008 Link to this post

    Is there a way to remove the add to dictionary option?

  4. Stanimir
    Stanimir avatar
    1653 posts

    Posted 05 Dec 2008 Link to this post

    Hi sayitfast,

    In order to remove the Add Custom option, you need to add the following line to the respective ConfigFile.xml.

    <property name="SpellAllowAddCustom">false</property> 

    ConfigFile.xml is located in Program Files\Common Files\Microsoft Shared\web server extensions\wpresources\RadEditorSharePoint\\Resources folder.

    ( depends on the control's version.

    Kind regards,
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  5. Mike Lee
    Mike Lee avatar
    2 posts
    Member since:
    Aug 2009

    Posted 13 Aug 2009 Link to this post

    I made the change to the config file as instructed, but the changes aren't picked-up even after re-opening the browser, re-compiling and clearing the cache. What could be keeping the tools from picking-up the change?
  6. Lini
    Lini avatar
    2144 posts

    Posted 14 Aug 2009 Link to this post


    The MOSS RadEditor has two configuration files - ConfigFile.xml and ListConfigFile.xml. The file that will be loaded depends on the scenario you are using the editor in (http://www.telerik.com/help/aspnet-ajax/set-properties-via-config-file.html). Make sure that you have set the SpellAllowAddCustom property in the correct configuration file. The change should be picked up the next time you open the editor (no restarts or clearing cache is required).

    All the best,
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Back to Top