Spark Line in Grid View and shows extra dots after scroll

9 posts, 0 answers
  1. Imran Javed Zia
    Imran Javed  Zia avatar
    55 posts
    Member since:
    Jul 2009

    Posted 25 Nov 2011 Link to this post

    Hi,
    We are using SparkLine in one column of GridView, we are getting issue that when user scrolls the grid down and move back then extra dots are visible in the grid. Please find the issue in attached image and we have also attached the sample code to regenerate the issue.
    we are using 2011.2.712.40 library build.

    Image file
    sparkline.jpg

    Sample code
    how can we attach the code?
    Thanks
  2. Yavor
    Admin
    Yavor avatar
    401 posts

    Posted 30 Nov 2011 Link to this post

    Hi Imran Javed Zia,

    We tried reproducing the problem in a simple test application and reproduced the problem partially. In our tests the line part of the sparkline shows correctly, but some indicators are displayed out of place. This happens when we tried scrolling the GridView up and down fast.

    You can attach the source code on a web site that offers free file sharing and send us the link. This way we can test it in our labs to see what is going on.

    All the best,
    Yavor
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. UI for WPF is Visual Studio 2017 Ready
  4. Imran Javed Zia
    Imran Javed  Zia avatar
    55 posts
    Member since:
    Jul 2009

    Posted 30 Nov 2011 Link to this post

    Hi Yavor,
    You have told to same steps and unexpected dots as we are facing, but there is fewer extra dots than we are observing. here is the example for more details download WpfApplication_SparkLine.zip from following url:

    https://skydrive.live.com/redir.aspx?cid=722083c5d931ed6a&resid=722083C5D931ED6A!176&parid=root

    Can you give me any idea, when we may get fixation of this bug?

    Thanks
  5. Yavor
    Admin
    Yavor avatar
    401 posts

    Posted 02 Dec 2011 Link to this post

    Hello Imran Javed Zia,

    Thank you for your sample project!

    This problem occurs when you have empty cells between your sparklines. If the sparklines in each row have items then this bug will occur less often. I have logged it in our issue tracking system and notified the responsible team.

    Please excuse us for the caused inconvenience!
    Your telerik points have been updated!

    Best wishes,
    Yavor
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  6. Imran Javed Zia
    Imran Javed  Zia avatar
    55 posts
    Member since:
    Jul 2009

    Posted 02 Dec 2011 Link to this post

    Hi Yavor,

    Can you give me approximate time for fixation of this bug and availability of fixed version?

    Thanks
  7. Vladimir Milev
    Admin
    Vladimir Milev avatar
    1061 posts

    Posted 06 Dec 2011 Link to this post

    Hello Imran Javed Zia,

    We will do our best to fix this problem for Q1 2012 release.

    Greetings,
    Vladimir Milev
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  8. Imran Javed Zia
    Imran Javed  Zia avatar
    55 posts
    Member since:
    Jul 2009

    Posted 06 Aug 2012 Link to this post

    Hi Vladimir Milev,
    We have just tried 2012.2.725.40 and have obsered same issue. It seems it has not been fixed yet.. if you like then can test same attached sample project with latest dlls.

    Thanks and Regards,
  9. Tsvetie
    Admin
    Tsvetie avatar
    1517 posts

    Posted 09 Aug 2012 Link to this post

    Hello Imran Javed Zia,

    The problem turned out to be more complex than expected and indeed we have not yet been able to fix it. The fix will require major refactoring of part of the logic in the control and I cannot commit a timeframe for this fix.

    Kind regards,
    Tsvetie
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  10. Tsvetie
    Admin
    Tsvetie avatar
    1517 posts

    Posted 16 Apr 2013 Link to this post

    Hi Imran Javed Zia,

    I am glad to inform you that the bug has been fixed and the fix will be part of the next internal build that we upload.

    All the best,
    Tsvetie
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

Back to Top
UI for WPF is Visual Studio 2017 Ready