Some Feedback on the new installation

16 posts, 1 answers
  1. Ben Hayat
    Ben Hayat avatar
    892 posts
    Member since:
    May 2008

    Posted 06 Nov 2008 Link to this post

    Congratulation to the Team for Q3 and the new site.

    I've noticed a few issues with the site, but first I like to report a few problems with the download.

    a) The DLL for the Gauges is missing. The Sample project does not compile.

    b) After installation, the Theme sample required Installation of the plugin. Seems like it was build with older version.

    c) On the website, the demo for "Job board" does not show any data.

    d) In this page http://www.telerik.com/products/silverlight/resources.aspx if you click on "Documentation", it will take you to "WPF" documentation.

    e) In this page http://demos.telerik.com/silverlight/carconfigurator/#tkagnav=CarConfigurator.LandingPage the Download source does not work.

    f) Where can I find the Theme sample.

    More to test...

    Can you send me the missing DLLs so I can test further?

    Thanks!
    ..Ben
  2. Valeri Hristov
    Admin
    Valeri Hristov avatar
    2252 posts

    Posted 06 Nov 2008 Link to this post

    Hello ..Ben,

    We are aware of the problems with the installation, that is currently online. We will change it very shortly (Nikolay is uploading the new files in this very moment).

    a) this will be resolved with the new distribution
    b) I wasn't able to reproduce that with the online sample
    http://demos.telerik.com/silverlight/themes/
    c) The Job Board will be updated tomorrow
    d) and e) I will tell the web team guys to fix those
    f) Valentin will be blogging about this very shortly, most probably tomorrow

    I think that it would be better to download the files that are online, because this is a forum thread and I cannot attach the developer assemblies here.

    Kind regards,
    Valeri Hristov
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. DevCraft banner
  4. Ben Hayat
    Ben Hayat avatar
    892 posts
    Member since:
    May 2008

    Posted 06 Nov 2008 Link to this post

    Hi Valeri;

    The Online Theme sample does the same: I have a screen shot jpg file, but how can I attach?

    >>I think that it would be better to download the files that are online, because this is a forum thread and I cannot attach the developer assemblies here.<<


    I'm uninstalling the old one and will download the new one.

    I would like to see the source to the "Car configuration" sample.

    Thanks!
  5. Ben Hayat
    Ben Hayat avatar
    892 posts
    Member since:
    May 2008

    Posted 06 Nov 2008 Link to this post

    Just to give you more info on the Theme sample. Found the problem. The bottom section where it shows menu and tab page, DOES NOT SHOW IN FF3
  6. Ben Hayat
    Ben Hayat avatar
    892 posts
    Member since:
    May 2008

    Posted 06 Nov 2008 Link to this post

    >>Nikolay is uploading the new files in this very moment).<<

    Is Nikolay using the same built # (1105) as the previous download? How would we know there is a new version up?

    Thanks!
  7. Seth
    Seth avatar
    23 posts
    Member since:
    Nov 2008

    Posted 06 Nov 2008 Link to this post

    I've manually added the Telerik controls to VS2008 but am getting an error when I try to add the Telerik.Windows.Controls.dll.  The error says that the Telerik.Windows.Data file or assembly could not load.  I believe this was an issue on one of the earlier verions of the Telerik tools?  Not sure.  Any idea on getting this assembly file?

    Update ...

    Sorry for jumping the gun on this post.  Looks like referencing the Telerik.Windows.Control.dll everything works fine.  But, the instructions on adding the Telerik.Windows.Control.dll as a control in the VS2008 ToolBox isn't working because its still giving the above described error.


    Regards,
    SMIMS
  8. Lee Fleming
    Lee Fleming avatar
    1 posts
    Member since:
    Oct 2008

    Posted 06 Nov 2008 Link to this post

    I am having the same problem. Can you let us know when the new version will be up?
  9. Serrin
    Serrin avatar
    286 posts
    Member since:
    Sep 2008

    Posted 06 Nov 2008 Link to this post

    I downloaded again a little while ago and the problem was solved...  If you do the auto-install, make sure it is putting Telerik.Windows.Data in the Binaries folder.  If that isn't there, you don't have the newest version of the download.  Haven't checked the manual install because the auto-install worked for me. :)
  10. Answer
    Valentin.Stoychev
    Admin
    Valentin.Stoychev avatar
    2198 posts

    Posted 06 Nov 2008 Link to this post

    Hello Ben,


    >>Just to give you more info on the Theme sample. Found the problem. The bottom section where it shows menu and tab page, DOES NOT SHOW IN FF3<<

    Thanks for pointing this out - this is a very strange problem actually.I'm still not sure what is causing this problem ... Will research it and will keep you posted with the progress.

    The problem is very interesting ... There are 2 Silverlight applications on the page - the top one (the one with color selector) is loading just fine, while the one below is giving the installation image. The only difference between these two is that the bottom app is loaded dynamically with Javascipt so we can pass the Theme parameter. Will let you know for more details later!

    BTW: Do you like the new themes - what is the first impression? :) We did a significant improvement in the way the themes are constructed, but more on that on a separate blogs post - watch on http://blogs.telerik.com the following days.


    Regards,
    Valentin.Stoychev
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  11. Ben Hayat
    Ben Hayat avatar
    892 posts
    Member since:
    May 2008

    Posted 06 Nov 2008 Link to this post

    >>BTW: Do you like the new themes - what is the first impression? :) We did a significant improvement in the way the themes are constructed, but more on that on a separate blogs post - watch on http://blogs.telerik.com the following days.<<

    After I read your blog and dig more into it the actual sample (once I get it), I'll then give you more input!
  12. Valentin.Stoychev
    Admin
    Valentin.Stoychev avatar
    2198 posts

    Posted 07 Nov 2008 Link to this post

    Hi All,

    The Themes for Silverlight example is now fixed to work in FF3.

    http://demos.telerik.com/silverlight/themes/

    Enjoy!

    BTW - this is just the first step towards building our own "3-click" silverlight style builder. More will be announced soon.

    Ofcourse any feedback on that is more than welcome.

    Kind regards,
    Valentin.Stoychev
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  13. Ben Hayat
    Ben Hayat avatar
    892 posts
    Member since:
    May 2008

    Posted 07 Nov 2008 Link to this post

    Valentin, your previous post raises a question. You said you have a second SL plugin control that the first one passes parameters. Does this mean, ONCE our application is up and running, we can not change the theme and see the new theme, UNTIL it is re-launched again?

    Thanks!
  14. Valentin.Stoychev
    Admin
    Valentin.Stoychev avatar
    2198 posts

    Posted 07 Nov 2008 Link to this post

    Hello ..Ben,

    Yes - this is a limitation in the Silverlight platform that we can not workaround. Even with the ImplicitStyleManager you need to re-initialize the pages to apply the new theme.

    But! - how important is for you to change the theme at runtime and to keep the state of the App?

    All the best,
    Valentin.Stoychev
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  15. Ben Hayat
    Ben Hayat avatar
    892 posts
    Member since:
    May 2008

    Posted 07 Nov 2008 Link to this post

    >>But! - how important is for you to change the theme at runtime and to keep the state of the App?<<

    At this point SL being so new in the market, I can ONLY speculate the following, but not necessarily a fact:
    In Winforms, where previously I had offered consumer to select a new theme, once the theme was selected, the could see the change right away without the need to start the application again. My fear is that, consumers will expect the same at least and if you tell them you're suppose to restart the app, the might think that this is stepping backwards with SL rather than forward. I understand your position and I just wanted to share the case.

    However, if you look at http://silverlight.net/samples/sl2/toolkitcontrolsamples/run/default.html the "Browse Theme" section, you can see that the theme gets changed while the app is still running. Is this something we can do with your theme?

    Thanks!
  16. Valeri Hristov
    Admin
    Valeri Hristov avatar
    2252 posts

    Posted 07 Nov 2008 Link to this post

    Hello Ben,

    The toolkit example also reloads some part of it in order to change the styles of the controls. This could be easily observable when you change the selection of several controls and then change the theme - the selection is lost.

    The problem with the themes is related to the fact that you can apply a style only once and the themes use styles to apply settings and control templates. Unfortunately it is unavoidable, unless we write some custom style framework that will enable us to apply our custom styles multiple times. However, I don't think it is worth the effort just because of the themes.

    Greetings,
    Valeri Hristov
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  17. Ben Hayat
    Ben Hayat avatar
    892 posts
    Member since:
    May 2008

    Posted 07 Nov 2008 Link to this post

    >>unless we write some custom style framework that will enable us to apply our custom styles multiple times. However, I don't think it is worth the effort just because of the themes.<<

    No, there are many other better things you can do with your resources than fixing this problem. This is MSFT/SL problem and not yours!

    Yes, you're right, the toolkit does loose the state after the reload. Thanks!


Back to Top
DevCraft banner