Smart Labels & Spider Mode - Lines Crossing

2 posts, 0 answers
  1. Geoffrey
    Geoffrey avatar
    23 posts
    Member since:
    Mar 2011

    Posted 23 Aug 2012 Link to this post

    I'm trying to implement a pie chart and I'm having some display issues. I have enables smart labels, spider mode and the connectors to show. However, for some scenarios the lines are going through the labels making it look bad. I have tried the label offset property but it did not help. The attached screenshot shows the chart. Any suggestions?
  2. Nikolay
    Admin
    Nikolay avatar
    385 posts

    Posted 28 Aug 2012 Link to this post

    Hi Geoffrey,

    Unfortunately this is an issue with the spider mode when having a number of pie slices with zero or very small values placed next to each other. There are a few approaches that may be applied dynamically, which you may find appropriate for such scenarios.

    The first one would be to disable the spider mode when there are a certain number of items with values of 0 ( or smaller than a certain value ). Another possibility would be to choose not to display labels for such values or for all values and instead use the legend to visualize them. Of course, there is always the alternative of using a different type of series, as for similar data sets as in the attached picture the bar chart type would generally be more appropriate.

    Regards,
    Nikolay
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  3. UI for WPF is Visual Studio 2017 Ready
Back to Top