SliderThumb disappears on expander resize

8 posts, 1 answers
  1. Simon Wolters
    Simon Wolters avatar
    20 posts
    Member since:
    Mar 2010

    Posted 21 Apr 2010 Link to this post

    Hello,

    I got a problem using the RadSlider control:
    The slider lays in a grid inside of an UserControl in the top center of my application. There are RadExpanders with some content to the left and right side of my UserControl. If one of those expanders is expanded, the grid containing the slider resizes accordingly.

    Now, if the SliderThumb is on the MaxValue of the SliderTicks (the very right tick) and the right expander is expanded to the left (making the grid that contains the slider smaller), the SliderThumb disappears. It reappears if the IsExpanded property of the right expander set to false again or once the user changes to slider value.

    It seems like the slider is resizing correctly but the SliderThumb is not moving along.

    Do you have any workaround for this?
    Thank you very much in advance.


  2. Vladislav
    Admin
    Vladislav avatar
    276 posts

    Posted 22 Apr 2010 Link to this post

    Hi Simon Wolters,

    I have prepared a sample project in the attached file for you.
    Can I ask you to check is this the proper implementation of the scenario described by you?
    Feel free to modify it in any way in order to reproduce your scenario exactly.

    After your review/response we can continue discuss the problem observed by you.

    Best wishes,
    Vladislav
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. DevCraft banner
  4. Simon Wolters
    Simon Wolters avatar
    20 posts
    Member since:
    Mar 2010

    Posted 22 Apr 2010 Link to this post

    Hi Vladislav,

    Indeed this is the correct scenario. As you can see in your sample project, once the thumb is set to the maximum value (very right side) of the slider, expanding either one of the expanders lets the thumb disappear.

    Thank you for your fast reply.
  5. Answer
    Kiril Stanoev
    Admin
    Kiril Stanoev avatar
    1512 posts

    Posted 26 Apr 2010 Link to this post

    Hi Simon,

    Thank you for your feedback. We have logged the item under the name "Slider: The thumb disappears when it is set to maximum value" in our PITS and it will be available for tracking tomorrow the latest. We will try to fix it as soon as possible. I've also added 1000 Telerik points to your account. Let me know if I can be of any further assistance.

    Best wishes,
    Kiril Stanoev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  6. Josh
    Josh avatar
    27 posts
    Member since:
    Feb 2012

    Posted 09 Jan 2013 Link to this post

    I'm going to resurrect an old problem here.  Has this been fixed?  I'm seeing a similar behavior where the slider is growing wider if the SelectedEnd value is set to the maximum.  I'm setting the width of the slider to 500 in the xaml and binding the SelectedEnd value.  When the value gets set, the right thumb moves to where the IncreaseButton was and the IncreaseButton jumps out to the right.
  7. Pavel R. Pavlov
    Admin
    Pavel R. Pavlov avatar
    1182 posts

    Posted 11 Jan 2013 Link to this post

    Hi Josh,

    I tried to reproduce your scenario on our side with our latest official release 2012.3.1129 and it seems that the code works as expected. Can you please take a look at the attached project and let me know if I missed something?

    Kind regards,
    Pavel R. Pavlov
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  8. Josh
    Josh avatar
    27 posts
    Member since:
    Feb 2012

    Posted 11 Jan 2013 Link to this post

    It must be the version we are using.  We're still on the Q1 controls and when I run this project with the dlls we have, I'm seeing the error I described. 
  9. Pavel R. Pavlov
    Admin
    Pavel R. Pavlov avatar
    1182 posts

    Posted 11 Jan 2013 Link to this post

    Hello Josh,
     
    We highly encourage to upgrade to Q3 2012 and take advantage  of the fixed version of RadSlider.

    Regards,
    Pavel R. Pavlov
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

Back to Top
DevCraft banner