slider doesnt slide under mouse

6 posts, 1 answers
  1. Thomas Kroll
    Thomas Kroll avatar
    9 posts
    Member since:
    Jan 2009

    Posted 28 Jun 2010 Link to this post

    Silverlight 4.0.50401.0 and q2 2010 beta

    the radslider will accelerate behind and past the mouse position when dragging.  The silverlight q1 2010 example had this "bug" too with Silverlight 4, but the example doesn't show this behavior anymore with q2 2010, however the projects I have still do.

    I have removed all telerik installations but the beta and only have silverlight 4 sdk, etc installed.  Still have the behavior as described occurring.

    Thanks in advance
  2. Answer
    Kiril Stanoev
    Admin
    Kiril Stanoev avatar
    1512 posts

    Posted 29 Jun 2010 Link to this post

    Hello Thomas,

    Could you please tell me the exact version of Telerik controls you are using. I managed to reproduce the issue with 2010.1.603.1040 (Service Pack). However with 2010.1.609.1040 (Beta) this issue has been fixed. Try downloading our latest internal build (2010.1.625.1040) and see if you still manage to reproduce the issue. I've attached my test project for further reference.

    Sincerely yours,
    Kiril Stanoev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. DevCraft banner
  4. Thomas Kroll
    Thomas Kroll avatar
    9 posts
    Member since:
    Jan 2009

    Posted 29 Jun 2010 Link to this post

    the latest internal build (2010.1.625.1040) applied to the project fixed the problem.

    Is there a way to get the old theme XAML for the slider controls?  I am not happy with the new themes available now as they are too thick.  Can you provide an easy way to get the Office_Black theme from Q3 2009 Xaml?  Should I just get it out of your source?

    Thanks in advance.
  5. Dimitrina
    Admin
    Dimitrina avatar
    442 posts

    Posted 02 Jul 2010 Link to this post

    Hi Thomas,

    Please find attached an example with a custom style of the RadSlider control.

    If you have further questions please do not hesitate to ask us.
    I hope this will help you.

    Greetings,
    Dimitrina
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Thomas Kroll
    Thomas Kroll avatar
    9 posts
    Member since:
    Jan 2009

    Posted 09 Aug 2010 Link to this post

    I am bringing this issue back up -

    When using a zoom level in ie/firefox, the behavior exists where the mouse doesn't follow the cursor.

    Restoring to 100% zoom solves the problem but needs to work in 125%, 150%, etc etc.

    Thanks in advance!
  7. Miro Miroslavov
    Admin
    Miro Miroslavov avatar
    588 posts

    Posted 12 Aug 2010 Link to this post

    Hello Thomas Kroll,

    Thank you for reporting it. I've created work item for it and will be fixed soon. You may vote for it on our PITS system to raise it's priority.
    Thank You.

    All the best,
    Miro Miroslavov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top
DevCraft banner