SiteMap

2 posts, 0 answers
  1. Janusz Oldakowski
    Janusz Oldakowski  avatar
    6 posts
    Member since:
    Nov 2008

    Posted 03 Mar 2010 Link to this post

    Does anyone knows if there is a problem with skinning the SiteMap? I have simple page

    <%

    @ Page Language="C#" AutoEventWireup="true" CodeFile="Default.aspx.cs" Inherits="Default" %>

     

    <!

     

    DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

     

    <

     

    html xmlns="http://www.w3.org/1999/xhtml">

     

    <

     

    head runat="server">

     

     

    <title></title>

     

     

    <telerik:RadStyleSheetManager id="RadStyleSheetManager1" runat="server" />

     

    </

     

    head>

     

    <

     

    body>

     

     

    <form id="form1" runat="server">

     

     

    <telerik:RadScriptManager ID="RadScriptManager1" runat="server">

     

     

    <Scripts>

     

     

    <asp:ScriptReference Assembly="Telerik.Web.UI" Name="Telerik.Web.UI.Common.Core.js" />

     

     

    <asp:ScriptReference Assembly="Telerik.Web.UI" Name="Telerik.Web.UI.Common.jQuery.js" />

     

     

    </Scripts>

     

     

    </telerik:RadScriptManager>

     

     

    <telerik:RadAjaxManager ID="RadAjaxManager1" runat="server">

     

     

    </telerik:RadAjaxManager>

     

     

     

    <telerik:RadSkinManager ID="RadSkinManager1" Runat="server" Skin="Black"

     

     

    ShowChooser="True">

     

     

    <TargetControls>

     

     

    <telerik:TargetControl ControlID="RadSiteMap1" />

     

     

    </TargetControls>

     

     

    </telerik:RadSkinManager>

     

     

    <div >

     

     

    <telerik:RadMenu ID="RadMenu1" runat="server"

     

     

    DataSourceID="RadSiteMapDataSource1"

     

     

    style="top: 0px; left: 0px; height: 16px; width: 773px">

     

     

    </telerik:RadMenu>

     

     

     

    <telerik:RadToolBar ID="RadToolBar1" runat="server"

     

     

    DataSourceID="RadSiteMapDataSource1">

     

     

    </telerik:RadToolBar>

     

     

    <telerik:RadSiteMap ID="RadSiteMap1" Runat="server"

     

     

    DataSourceID="RadSiteMapDataSource1" ShowNodeLines="True" >

     

     

    </telerik:RadSiteMap>

     

     

    <telerik:RadSiteMapDataSource ID="RadSiteMapDataSource1" runat="server" ShowStartingNode="false" SiteMapFile="~/Web.sitemap"/>

     

     

    </div>

     

     

    </form>

     

    </

     

    body>

     

    </

     

    html>

     

     

     

     

     

    The black skin selected seems to be working on the Menu and the Toolbar controls, but for the sitemap it does not. At least it does not work the same as on Telerik's demo site.

     

    Does anyone know what am I missing or is it a bug, or what?

  2. Genady Sergeev
    Admin
    Genady Sergeev avatar
    1596 posts

    Posted 09 Mar 2010 Link to this post

    Hi Janusz Oldakowski ,

    As far as I can see the Black skin looks the same on my sample project and on the demos. The only difference is that on the online demos there is black background applied. This is in no way connected to the sitemap itself nor to any other RadControl but is a part of the online demos layout.

    I have attached my sample project for reference.

    Kind regards,
    Genady Sergeev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top