Single point LineSeries is rendered correctly first time but incorrectly after you add and then remove a point

3 posts, 0 answers
  1. Alex
    Alex avatar
    6 posts
    Member since:
    Jun 2011

    Posted 25 Mar 2014 Link to this post

       Hi,
       If you bind a single point collection to the LineSeries it displays an empty chart area which in understandable, there is no second point to draw the line to but if you add another point to the bound ObservableCollection and then remove it it displays a line between two points first (so far so good) but then after you remove the added point and you have only a single point in the collection again it still displays the last drawn line.
       Is there a fix for this situation or workaround?

    Thank you,
    Alex
  2. Alex
    Alex avatar
    6 posts
    Member since:
    Jun 2011

    Posted 03 Apr 2014 in reply to Alex Link to this post

       Does anybody have any ideas?
  3. DevCraft banner
  4. Ivaylo Gergov
    Admin
    Ivaylo Gergov avatar
    661 posts

    Posted 08 Apr 2014 Link to this post

    Hello,

    I tried to reproduce this scenario but with no avail. I have attached a project that demonstrates this approach and everything works as expected on our side. Could you please take a look and modify it in order to reproduce the issue?

    Regards,
    Ivaylo Gergov
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
Back to Top