Silverlight upgrade

9 posts, 1 answers
  1. Claude
    Claude avatar
    63 posts
    Member since:
    Apr 2009

    Posted 23 Dec 2012 Link to this post

    Just upgraded to the latest version and now there are only a few Telerik controls in toolbox.  Also, when I want to create a new project there is no listing for a Telerik silvrlight app.  I have uninstalled and reinstalled to no avail.

  2. Dimitrina
    Admin
    Dimitrina avatar
    3769 posts

    Posted 24 Dec 2012 Link to this post

    Hello,

    Would you please share a little bit more details on what version of Visual Studio do you have? Have you installed the controls through the .msi file, or using the ControlPanel?

    As for the missing controls in the ToolBox, you can try adding them manually. Does this help?

    Kind regards,
    Didie
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  3. DevCraft banner
  4. Claude
    Claude avatar
    63 posts
    Member since:
    Apr 2009

    Posted 24 Dec 2012 Link to this post

    VS 2010.  Installed using the Control Panel.   

    I have tried to add the controls, but they are not listed.   Where is the msi file installed?

  5. Dimitrina
    Admin
    Dimitrina avatar
    3769 posts

    Posted 24 Dec 2012 Link to this post

    Hello,

    You can download the .msi installation file here after you login into your account. Its default install destination is "C:\Program Files (x86)\Telerik".

    Have you followed the instructions for adding controls to the ToolBox given in this help article?

    Regards,
    Didie
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  6. Claude
    Claude avatar
    63 posts
    Member since:
    Apr 2009

    Posted 24 Dec 2012 Link to this post

    I finally got the toolbox working, but no themes.  As well as no template for a telerik silverlight application on new project.

  7. Dimitrina
    Admin
    Dimitrina avatar
    3769 posts

    Posted 26 Dec 2012 Link to this post

    Hello,


    May I ask you to try the following:

  8. Start a Visual Studio 2010 Command Prompt (Start menu -> Microsoft Visual Studio 2010 -> Visual Studio Tools -> Visual Studio 2010 Command Prompt) and run the following command: devenv.exe /resetskippkgs
  9. Watch for a possible error during the Visual Studio startup and check the Telerik menu.

I hope this will help.

All the best,
Didie
the Telerik team

Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  • Claude
    Claude avatar
    63 posts
    Member since:
    Apr 2009

    Posted 26 Dec 2012 Link to this post

    No errors were observed.   On telerik menu only winforms and asp.net ajax show up.  In any event I have all the tools, etc, just not the templates of creating a rad silverlight project. 
  • Answer
    Andrey
    Admin
    Andrey avatar
    244 posts

    Posted 28 Dec 2012 Link to this post

    Perhaps something went wrong with our VSExtensions deployment. You should be able to fix that by simply reinstalling it through the Visual Studio Extension Manager. Here are some steps for doing that:
    1. Open the Extension Manager (Tools -> Extension Manager...)
    2. Remove the Telerik Silverlight VSExtensions extensions
    3. Select the Online Gallery tab
    4. Type telerik vsextensions in the search field
    5. Redownload the Telerik Silverlight VSExtensions

    Let me know if that helps.

    Kind regards,
    Andrey
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  • Claude
    Claude avatar
    63 posts
    Member since:
    Apr 2009

    Posted 28 Dec 2012 Link to this post

    that did the trick - thanks..

  • Back to Top
    DevCraft banner