showWorkHours: false not working

2 posts, 0 answers
  1. Boris
    Boris avatar
    15 posts
    Member since:
    Aug 2015

    Posted 04 Feb Link to this post

    Hello,

    I try to apply showWorkHours:false on day view on my sheduler, according to this manual: http://docs.telerik.com/kendo-ui/api/javascript/ui/scheduler#configuration-showWorkHours

     

    It looks like this:

      views: [
                {
                    type: "day",
                    showWorkHours: false,

        ...}

     But on my sheduler in day view there are still grey slots from 17:00 and later. With the class: k-nonwork-hour.

    Am I missunderstanding this fucntion, or is there some some possibility, that something is overwriting shis setting?

     

    Thanks for your answer.

  2. Vladimir Iliev
    Admin
    Vladimir Iliev avatar
    2172 posts

    Posted 08 Feb Link to this post

    Hello Boris,

    This is expected as the "showWorkHours" option controls the "startTime" / "endTime" of the Scheduler but not the work day hours (respectively the gray slots). To remove the gray coloring of the non work hours you  should set "workDayStart" / "workDayEnd" as follows:

    workDayEnd: new Date("2013/1/1 11:59 PM"),
    workDayStart: new Date("2013/1/1 00:00 AM"),
     
    Regards,
    Vladimir Iliev
    Telerik
     
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
     
  3. Kendo UI is VS 2017 Ready
Back to Top