Show HTTPS in Protocol column instead of HTTP for port 443 requests

4 posts, 0 answers
  1. Dave
    Dave avatar
    2 posts
    Member since:
    Nov 2015

    Posted 19 Nov 2015 Link to this post

    The Protocol column always shows HTTP but HTTPS requests will show :443 in the URL column, and I would rather it show the actual URL being requested and HTTPS shows for port :443 requests (unless I'm misunderstanding if HTTPS is just some conceptual nickname for HTTP port 443).
  2. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 19 Nov 2015 Link to this post

    Hello, Dave--

    This is a common misunderstanding; see http://textslashplain.com/2015/11/19/understanding-connect-tunnels/ for an explanation of proxy tunnels.

    If you haven't yet enabled HTTPS decryption (Tools > Fiddler Options > HTTPS), you'll need to do so before you see the encrypted contents of the proxy tunnel.

    Regards,
    Eric Lawrence
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Dave
    Dave avatar
    2 posts
    Member since:
    Nov 2015

    Posted 20 Nov 2015 in reply to Eric Lawrence Link to this post

    All of my web traffic in Internet Explorer is going through Fiddler?

    I don't need to see the unencrypted content, but is Fiddler able to see that and what does it do with it?

  4. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 20 Nov 2015 Link to this post

    Hi, Dave--

    It might be helpful to step back a bit-- for what task are you using Fiddler?

    By default, Fiddler registers itself as the system's proxy server on startup, and traffic from web browsers (IE, Chrome, Firefox, etc) flows through Fiddler for inspection. If you enable HTTPS decryption, Fiddler will perform its man-in-the-middle technique and will show the plaintext traffic; if you do not, Fiddler cannot "read" the traffic and simply blindly forwards it back and forth through the tunnel as described.

    If you don't want Fiddler to capture traffic from anything on your system (because, say, you're only using the Composer feature) then you can easily untick File > Capture Traffic and/or click Tools > Fiddler Options > Connections and untick the "Act as system proxy on startup" checkbox.

    Regards,
    Eric Lawrence
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top