Shift+Tab is not working for RadDatePicker

5 posts, 0 answers
  1. lakshmi jeeva
    lakshmi jeeva avatar
    20 posts
    Member since:
    Jul 2012

    Posted 10 Jul 2012 Link to this post

    Hi,

       I have created a UserControl. In that i am having a RadDatePicker and two timepickers. I am using that UserControl in my dialog. Please select Date and time and click Shift+Tab . It is working fine.

      Please dont select anything in RadDatePicker (ie., RadDatePicker is empty) and select time in two time pickers. Please press Shift+Tab from last time picker. It is going to previous time picker. From that please press Shift+Tab. Focus is not going to RadDatePicker. If RadDatePicker having date then the focus is going but if it is empty it is not working.If i directly use the raddatepicker without using any usercontrolit is working. If i will use UserControl the reverse tab order(Shift+Tab) is not working. I am using Q2 2012 version.

    Regards
    Lakshmi
  2. Georgi
    Admin
    Georgi avatar
    347 posts

    Posted 13 Jul 2012 Link to this post

    Hi Lakshmi,

    I have tried to reproduce the issue, but with no luck. I am attaching my test project and a video showing what I have tried. It would be great If you can check it out and let us know if we are doing the same thing. Also I am using Q2 2012 dlls.
    If you also can't reproduce it in the attached project a simple project or code would be appreciated.

    Regards,
    Georgi
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. DevCraft banner
  4. Shimoli
    Shimoli avatar
    16 posts
    Member since:
    May 2011

    Posted 20 Aug 2012 Link to this post

    I am also getting same issue.
    I have put 3 RadDatePicker into my UserControl. If 1st RadDatePicker has no Date Selected and Second Rad Date picker has value selected.
    Now, If I am going on Third RadDatePicker control and I am pressing Shift +Tab. It is going to select Second RadDatePicker (having value). But on second time Shift+Tab key press,It is not able to move on 1st RadDatePicker control(as it has not value selected.)

    Please guide me for the same.

  5. Georgi
    Admin
    Georgi avatar
    347 posts

    Posted 23 Aug 2012 Link to this post

    Hi Shimoli,

    I was able to reproduce the issue using  Q1 2012 SP (2012.1.326.1050), but I was not able to reproduce it with any newer version of the controls. Therefore the issue should be fixed in Q2 2012 , it would be great if you can give it a try and let us know if everything works as expected. I am also attaching a video showing how it behave with Q2 2012 assemblies .


    All the best,
    Georgi
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  6. Shimoli
    Shimoli avatar
    16 posts
    Member since:
    May 2011

    Posted 29 Aug 2012 Link to this post

    Hi,

    Thanks for the reply. New version has solved my issue. It's working as required.

    Thanks and Regards,
    Shimoli Shah
Back to Top
DevCraft banner