Severe rendering problems

2 posts, 0 answers
  1. Bryan
    Bryan avatar
    9 posts
    Member since:
    Jan 2015

    Posted 05 Dec 2015 Link to this post

    For some time, I've noticed some severe rendering problems when using Kendo numeric/integer text box widgets. Here's the scenario:

    Currently, I'm using the latest version of everything (Windows 10 with update 1511, VS 2015 Update 1, latest Kendo), although the problems I'm seeing date back to Window 8/8.1 and VS 2013.

    I've got an MVC app using Bootstrap.

    In the particular case that I'm working on right now, I've got a form inside a dialog box (Kendo Window widget) that uses a number of different Kendo widgets for input (TextBox, DropDownList, IntegerTextBox).

    When I use the IntegerTextBox (or other numeric) widget, rendering consistently just goes all to hell in the dialog box. Spinners disappearing are the least of it. A lot of the time, all the other HTML elements in the dialog box are being overlaid by something. When I move the mouse over various controls, they sometimes appear and sometimes disappear. Clicking on one of the numeric text boxes tends to make everything else disappear. If I remove all numeric text box widgets from the form, the problems disappear completely. Removing the form itself has no impact. Removing validators has no impact.

    This occurs in both IE and Edge browsers, but only on my desktop system, never on my laptop or my Surface Pro 3. My desktop system has a second generation i7-2600 with Intel HD Graphics 2000. My laptop has a fourth generation i7-4700HQ with Intel HD Graphics 4600. My Surface Pro 3 has a fourth generation i5-4300U with Intel HD Graphics 4400. I don't see these types of problems when I surf around the web, just in the apps I'm developing with Kendo.

    I'm almost at the point of having to buy another desktop computer with a newer processor/graphics just so I can do my work. The problem with that, as my wife wisely points out, is that my customers may run into this problem with the deployed app. Judging by other forum threads, other developers are seeing similar things, but no one seems to have been able to come up with an example that you can duplicate. I suggest you get a system similar to my desktop machine and try it on that. I think the problem is related to the interaction between the Intel HD Graphics 2000, Windows 8x/10, and Kendo. Intel has essentially dropped support for their HD Graphics 2000/3000 for version of Windows greater than 7 although, obviously, Windows 8x/10 installs and seems to otherwise work on those systems.


     
     
     
  2. Georgi Krustev
    Admin
    Georgi Krustev avatar
    3707 posts

    Posted 09 Dec 2015 Link to this post

    Hello Bryan,

    I answered to the other forum thread opened on the same subject. I would like to ask you continue our discussion in only one thread to avoid duplication.

    Here is a link to the other thread:
    Regards,
    Georgi Krustev
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. UI for ASP.NET MVC is VS 2017 Ready
Back to Top