Setup Wizard ended prematurely - Uninstall

5 posts, 0 answers
  1. Henry
    Henry avatar
    35 posts
    Member since:
    Mar 2009

    Posted 17 Oct 2010 Link to this post

    Hi,
    I'm trying to uninstall "Telerik.Web.UI_2010_2_826_Trial" so that I can install the latest version, however during uninstall, I get the following message:

    "Telerik RadControls Setup Wizard ended prematurely because of an error.,...."

    Please see the link below for the log file generated by the msi installer.
    http://cid-694a1ac153d587e5.office.live.com/self.aspx/Public/install.log.zip

    Many Thanks,
    Henry Wu
  2. Andrey
    Admin
    Andrey avatar
    244 posts

    Posted 18 Oct 2010 Link to this post

    Hi Henry,

    After reviewing your log, I was able to pinpoint the error you are experiencing. To my regret, I was not able to identify the underlying cause.

    I would recommend performing a repair using the original installation package, before attempting another uninstall.

    Please, do not hesitate to contact us if you experience any further issues.

    Kind regards,
    Andrey
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Henry
    Henry avatar
    35 posts
    Member since:
    Mar 2009

    Posted 24 Oct 2010 Link to this post

    Hi,
    I did the following in order:
    1) msiexec /i Telerik.Web.UI_2010_2_826_Trial.msi /limev Telerik.Web.UI_2010_2_826_Trial-REPAIR.log
    2) msiexec /i Telerik.Web.UI_2010_2_826_Trial.msi /limev Telerik.Web.UI_2010_2_826_Trial-UNINSTALL.log
    3) msiexec /i Telerik.Web.UI_2010_2_929_Trial.msi /limev Telerik.Web.UI_2010_2_929_Trial-UPGRADE.log

    No. 1 - repairing the original installation - this one completed successfully.
    No. 2 - uninstall the original installation - this one failed - same error message.
    No. 3 - trying to upgrade from a newer version and upgrade the previous version - this one failed.

    Please see the log files in the attached file.
    Any way to simply remove the original installation? I would like to use the latest version asap.

    http://cid-694a1ac153d587e5.office.live.com/self.aspx/Public/Telerik.Web.UI%20Log%20Files.zip

    Many Thanks,
    Henry Wu
  5. Andrey
    Admin
    Andrey avatar
    244 posts

    Posted 25 Oct 2010 Link to this post

    Hello Henry,

    The uninstallation you are trying to run fails at loading an assembly which should be packed into the installation package.

    Perhaps if you add the assembly in your Global Assembly Cache, the uninstallation process would successfully load it.

    The above-mentioned assembly can be found in the attached zip file.

    All the best,
    Andrey
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Henry
    Henry avatar
    35 posts
    Member since:
    Mar 2009

    Posted 26 Oct 2010 Link to this post

    Hi,
    I finally got it uninstalled successfully.
    It turns out that the after clicking the uninstall button, the UAC pop-up did not show up, after running the .msi file in a command-prompt window launched with "Run-as Administrator", everything went okay.

    I'm running on Windows 7 Ultimate.

    The Telerik.Web.UI_2010_2_929_Trial.msi installed successfully, it launched the UAC pop-up as well (after clicking the install button), even without the command-prompt in admin rights trick.

    Many Thanks,
    Henry Wu
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017