Setting IsTabStop="False" doesn't do anything

2 posts, 1 answers
  1. danparker276
    danparker276 avatar
    389 posts
    Member since:
    Aug 2010

    Posted 30 Jan 2013 Link to this post

    Shouldn't I be able to remove this from the tab order with this command?  It still tabs to the buttons and all.

    Also the radcombo box is like that too.
  2. Answer
    Kiril Vandov
    Admin
    Kiril Vandov avatar
    324 posts

    Posted 04 Feb 2013 Link to this post

    Hello danparker276,

    This is the expected default behavior for the RadSlider in order to prevent the Slider from compleatelly ignoring the tab key you could use those two approaches:
    -If you want to avoid focusing the Slider in WPF  you could set KeyboardNavigation.TabNavigation =None.
    -If you want to avoid focusing the Slider in SL you could make custom styles setting the Increase/Decrease handles and the thumb IsTabStop property, by changing "IncreaseHandleStyle", "DecreaseHandleStyle", "ThumbStyle", "SelectionMiddleThumbStyle" styles.

    I hope this information helps.

    Kind Regards,
    Kiril Vandov
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  3. DevCraft banner
Back to Top