Set title in show-before doesn't work

7 posts, 0 answers
  1. axel
    axel avatar
    51 posts
    Member since:
    Jan 2010

    Posted 08 Nov 2015 Link to this post

    Hello,

    since 2015 Q3 i cannot set the title in a show-before function.

    example

    With 2015 Q2, it works as expected.

     

     Kind regards

     

  2. axel
    axel avatar
    51 posts
    Member since:
    Jan 2010

    Posted 08 Nov 2015 Link to this post

    http://dojo.telerik.com/iBOHU

    I'm probably too stupid for it...

  3. Kendo UI is VS 2017 Ready
  4. Petyo
    Admin
    Petyo avatar
    2438 posts

    Posted 09 Nov 2015 Link to this post

    Hello axel,

     

    sorry for the inconvenience, we made some changes in the navbar title logic and it seems to have broken your approach. You may use the after-show event for that purpose.

     

    Regards,
    Petyo
    Telerik
     
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
     
  5. axel
    axel avatar
    51 posts
    Member since:
    Jan 2010

    Posted 09 Nov 2015 Link to this post

    Hi Petyo,

    I'm sorry, but after-show is not a good solution if you have several views. The transition appears choppy.

    http://dojo.telerik.com/afAbu

    best regards

    axel

  6. Petyo
    Admin
    Petyo avatar
    2438 posts

    Posted 10 Nov 2015 Link to this post

    Hello axel,

     

    you can do something like this.

     

    Regards,
    Petyo
    Telerik
     
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
     
  7. axel
    axel avatar
    51 posts
    Member since:
    Jan 2010

    Posted 10 Nov 2015 Link to this post

    I'm sorry that I'm so fussy, but when different views have the same title, it flickers.

    http://dojo.telerik.com/umIJA

    But it's better than before in any case.

    Thanks for your help

     
  8. Petyo
    Admin
    Petyo avatar
    2438 posts

    Posted 12 Nov 2015 Link to this post

    Hello axel,

     

    yes, unfortunately this is so. There is not much to do here, I am afraid. The behavior you observe is related to the auto-title-fetch behavior of the navbar (and to its auto-hiding implementation). In general, the view title should be specified via the data-title attribute of the view, with the manual method call being the exception. 

     

    Regards,
    Petyo
    Telerik
     
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
     
Back to Top
Kendo UI is VS 2017 Ready