Service Endpoint Not Found

3 posts, 0 answers
  1. Jake
    Jake avatar
    2 posts
    Member since:
    Jun 2012

    Posted 25 Jun 2012 Link to this post

    Hey All,

    I have a number of services hosted on a different domain referenced properly in the code behind and in the app config. I am positive that the contract names are correct in the app config and that the end points as serving valid wsdl files yet I am still getting an error saying that the endpoint contract can't be found or I dont have an app config. Please assist, I am at my wits end!

    -Jake
  2. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 27 Jun 2012 Link to this post

    Hello Jake,

    The provided information is insufficient for us to determine what is your problem. We have the following questions:
    • You talk about "number of services hosted" - are these Telerik Reporting WCF Services?
    • What is the purpose of hosting them on separate domain and have you verified the ReportViewer.ReportServiceUri is correct?
    • Do you get any errors when you access the .svc files directly in browser?
    • What is the response from the server if you use an http debugging proxy like Fiddler to track down the problem?

    Regards,
    Steve
    the Telerik team

    FREE WEBINAR ON THE NEW REPORT DESIGNER! Join us on Friday, June 29 at 10:00 AM PST for a comprehensive demo of the official version of the standalone Report Designer and find out how easy it is to empower your users with creating, editing and sharing ad-hoc reports. You may even win a free Telerik Ultimate Collection license! Register today >>

  3. DevCraft banner
  4. Jake
    Jake avatar
    2 posts
    Member since:
    Jun 2012

    Posted 27 Jun 2012 Link to this post

    The web services are hosted on a separate domain and provide the data for the telerik reports which is set up in the code behind. These services are not telerik services but Web Services added by adding a service reference in visual studio. We see no error when we view the reports on our page just we we try to preview them in visual studios. Thanks for your help!
    -Jake
Back to Top