Server Exception while building the app.

7 posts, 0 answers
  1. Purna
    Purna avatar
    17 posts
    Member since:
    May 2012

    Posted 06 Nov 2014 Link to this post

    I'm unable to build Android app using AppBuilder. I get this weird error, and I'm not sure how I must solve it. 

  2. Zdravko
    Admin
    Zdravko avatar
    657 posts

    Posted 11 Nov 2014 Link to this post

    Hi Purna,

    We recently received a few complaints regarding the error you have received and we are investigating the culprit for it.
    However, we want to gather as much information as possible so I have a few questions on the matter.
    • Did you follow the requirements for constructing Nine patch image?
    • Would you share with us the picture you use in a private ticket?
    • Did you have such issue before our latest release or you started using the picture after the update?
    As the error says, there is an issue with the Android splash screen and in order to get rid of it while we look for the culprit you can replace it with our default splash screen that comes in the App_resource folder > Android > drawable-nodpi when create a project for very first time.

    Furthermore, I suggest using our Windows client where a better verification is implemented when you try to upload new picture.
    Despite the fact you can't build your app in the in-browser client I suspect that the build may pass using the Windows client so consider trying this as a workaround.

    I look forward to your reply.

    Regards,
    Zdravko
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  3. Purna
    Purna avatar
    17 posts
    Member since:
    May 2012

    Posted 11 Nov 2014 in reply to Zdravko Link to this post

    Zdravko, 
    If I could have used a Windows client, I would have. I'm on OS X, and that's not an option. As much as I hate running a Virtual Machine just to use your product, I did that, and your Windows client has a bunch of other issues. Can't revert, can't commit, can't pull. 

    Issues like these seriously hamper productivity, and the whole point of choosing AppBuilder was to make life easier for developers, unfortunately that has not been the case. It's an endless struggle to even do simple things like pull or push. 

    To know what I'm talking about, please have a look at the screen recording. 

    https://dl.dropboxusercontent.com/u/29657897/appbuilder-mess.mov (since I cannot attach video files here)
  4. Purna
    Purna avatar
    17 posts
    Member since:
    May 2012

    Posted 11 Nov 2014 Link to this post

    As far as the nine patch images goes, since the time I included the nine patch file in our project, it has never been changed, and yes, I did follow the requirement and it was working just fine for months before it stopped working with no fiddling from my part. 
  5. Zdravko
    Admin
    Zdravko avatar
    657 posts

    Posted 14 Nov 2014 Link to this post

    Hi Purna,

    Thanks for your reply.
    I didn't know that you are on OS X machine otherwise I would suggest building your app using two more options - our CLI and Sublime. Please accept my apologies for not providing this information in the first place.

    As I already mentioned we logged the splash screen issue for further examination and as another workaround you can try whether repainting your black splash screen border pixels helps.
    The same error was caused on another user's side because of not completely black or transparent pixels as the Nine patch requires.

    I understand that this picture has been working without any problems for a while but we will need more time to investigate what has changed in our verification.
    It would be of great help if you send us your picture so we can test with it. You can attach it to a private ticket open by you.

    Regarding your version control issue, I would say that we haven't seen such before and we will try to reproduce it following your steps. Thank you very much for the video you have made for us.

    Please let me know if I can be of further assistance.

    Regards,
    Zdravko
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  6. Dan
    Dan avatar
    26 posts
    Member since:
    Jan 2013

    Posted 30 Nov 2014 Link to this post

    Same error..Patch 9 malformation error .even though it is the same patch  9 image we have always used for this project.

  7. Dan
    Dan avatar
    26 posts
    Member since:
    Jan 2013

    Posted 01 Dec 2014 in reply to Purna Link to this post

    Purna .. use the tool that Owidat provided.. just run your image and it will fix what ever is wrong with your image ..takes 2 seconds and you wont get the malformation error anymore

    http://www.telerik.com/forums/android-splashscreen---this-isn't-a-valid-9-patch-image-
Back to Top