Server 2012 - IE10 - RT - Clear Browser Cookies hang

3 posts, 1 answers
  1. Jon
    Jon avatar
    55 posts
    Member since:
    May 2012

    Posted 07 Jan 2013 Link to this post

    I am having a problem with the test studio run time where the test studio run time will stop & hang on server 2012 (IE10) when I Clear Browser Cookies. The screen capture attached has been sitting there for more then an hour.

  2. Answer
    Shtilianov
    Admin
    Shtilianov avatar
    6 posts
    Member since:
    Sep 2012

    Posted 10 Jan 2013 Link to this post

    Hi Jon,

    There are a number of reasons why clear cookies doesn't work. I wasn’t able to reproduce the issue myself so I'll ask you to try a few things.

    1. In Server OS IE is behaving slightly different (there a lot of permissions to be tackled and insufficient permission could fail the clear cookies step). In order to verify that's not the problem just create an empty test case and add clear cookies step and see if it passes or not.
    2. Go to Help tab in test studio and enable "Logging" (if it's already enabled, clear it), execute the test cases where the runner freezes on clear cookies and send me the log (or paste the appropriate exception if present).
    3. Check IE10 settings, you can open Test Studio ---> Project View --> Project Settings --> Browsers --> Calibrate IE10 settings (make sure that IE status is green.
    4. Another thing you can try is to move the "Clear browser cookies" step before the "Logout" step. Sometimes Clear cookies will fail to do anything if the session is dead. It shouldn't be like that in IE ,but still it's worth trying.
    5. If nothing else works, it will be very helpful if you can send us the test case so we can try to reproduce the issue locally (there is no need the test to be working, we'll try to copy using a similar setup).


    Greetings,

    Miroslav

    the Telerik team

    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings

  3. Jon
    Jon avatar
    55 posts
    Member since:
    May 2012

    Posted 18 Jan 2013 Link to this post

    Hi Miroslav

    Sorry for the late reply.

    I had a conference call with Cody and Carrie, it was determined that our version was out of date. With the new version this feature is working great.

    Thanks
    Jon

Back to Top