Selected Style Not Applied

2 posts, 1 answers
  1. Bruce
    Bruce avatar
    27 posts
    Member since:
    Oct 2010

    Posted 23 May Link to this post

    I am using a RadListView whoseSelectionMode is Single.  I am programmatically adding an item to the SelectedItems collection.  However, when I do so, the style of the row corresponding to the item does not change, indicating to the user that the row is selected.  This is an issue for both Android and iOS.

    I experimented with removing the existing selected item from SelectedItems before adding the new one.  Doing so did not help.

  2. Answer
    Lance | Tech Support Engineer, Sr.
    Admin
    Lance | Tech Support Engineer, Sr. avatar
    362 posts

    Posted 23 May Link to this post

    Hello Bruce,

    I can reproduce this and recommend that you open a support ticket so that the dev team can investigate further. You have a full license for UI for Xamarin support and can open a support ticket here.

    I'll keep a close eye on the support thread once you submit the ticket to make sure everything goes smoothly.

    Side Note:
    Support tickets carry a guaranteed response from the support team. Although we try to monitor the public forums, this can be limited to available resources which can lead to delays otherwise prevented by opening a ticket.

    Regards,
    Lance | Tech Support Engineer, Sr.
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top