Select event not firing with opacity slider

2 posts, 1 answers
  1. Andrew
    Andrew avatar
    4 posts
    Member since:
    Jun 2012

    Posted 16 Apr 2013 Link to this post

    I'm trying to use the Kendo UI colour picker with the opacity slider, which the documentation describes as being available if you use the hsv selector. 

    If I use the hsv selector and change the RGB values first, all select events fire normally. However if I try and change the opacity first using the opacity slider, the select event doesn't fire, and therefore the colour doesn't update to reflect the new opacity value. If I change the rgb colour values at any stage, the select event then fires normally from then on.

    So basically there seems to be an issue if the user only wishes to change the opacity of particular colour, but does not need to change the RGB values for the colour. 

    Can anyone confirm whether this is a bug?  It is happening in IE9 and Chrome for me, Kendo UI Q1 2013 release.  
  2. Answer
    Dimiter Madjarov
    Dimiter Madjarov avatar
    2122 posts

    Posted 16 Apr 2013 Link to this post

    Hello Andrew,

    Thank you for bringing this issue at our attention. I managed to reproduce it and it is logged for fixing from the development team.

    I also updated your Telerik points as a small sign of gratitude.
    Wish you a great day!


    All the best,
    Dimiter Madjarov
    the Telerik team
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
Back to Top