Scheduler in IE8 mode

3 posts, 0 answers
  1. Martin de Ruiter
    Martin de Ruiter avatar
    99 posts
    Member since:
    Jun 2005

    Posted 20 Mar 2009 Link to this post

    As you probably know, IE8 has just been released, so I guess you officially support it now, right? Currently I'm trying to make an application fully compatibly with IE8, by adding the following meta tag:
    <meta http-equiv="X-UA-Compatible" content="IE=8"/>

    However, when I use that the RadScheduler won't display properly. I noticed on your demopages that you use the IE7 meta tag:
    <meta http-equiv="X-UA-Compatible" content="IE=7"/>

    This makes it work, but of course is not ideal. Are you still working on it to make it fully IE8 compatible?

    Btw, when I use a styleSheetTheme in the web.config (for use of skinning and a css file), it seems that the meta tag doesn't get recognized. When you use Theme instead of styleSheetTheme it works, but I need the second one. Do you know what's going wrong there?

    Kind regards,
    Martin de Ruiter
  2. Atanas Korchev
    Admin
    Atanas Korchev avatar
    8462 posts

    Posted 23 Mar 2009 Link to this post

    Hi Martin de Ruiter,

    We still do not support IE8 officially. There are known issues which we will address with the upcoming service pack.

    We are not aware of the problem with the stylesheet theme and the meta tag. I am not sure if this is in any way related with RadControls for ASP.NET Ajax. Could you please elaborate?

    Regards,
    Albert
    the Telerik team

    Check out Telerik Trainer , the state of the art learning tool for Telerik products.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Martin de Ruiter
    Martin de Ruiter avatar
    99 posts
    Member since:
    Jun 2005

    Posted 23 Mar 2009 Link to this post

    Hi Albert,

    Okay, good to know you are resolving the issues, looking forward to the service pack.

    The problem with the stylesheet theme and metatag is indeed not related to your controls (that's why I asked in the community forums instead of using a support ticket ;-), but I found a solution: if you have a skin file and a css file in your themes, just use the StyleSheetTheme tag for the skin file, and use the Theme tag for the css file. This way you can still have the IE8 meta compatibility tag in the right place (first item in the head) and use the theming options. I also informed the ASP.NET team and they told me they will resolve this issue in ASP.NET 4.0.

    Kind regards,
    Martin
Back to Top