Scheduler display problems in IE/Firefox

4 posts, 0 answers
  1. Ian
    Ian avatar
    129 posts
    Member since:
    Jun 2009

    Posted 08 Jul 2010 Link to this post

    Hi. I'm experiencing some display problems using a Scheduler control on an intranet page. In IE8, there's a 7px gap between the scheduler header and the table that contains the main scheduler appointment information (see screenshot 1). In Firefox 3.6, the same table is shifted around 90px right (see screenshot 2).

    Using IE dev toolbar and Firebug, I've conclued the .rsContent div is positioned OK and that the problems arise with the child table being shifted down or right. I know the issue is being caused by global CSS rules in the intranet page style sheet interfering with the scheduler CSS settings but I'm really struggling to find out what's being overidden and causing the problems.

    Is there any way I can insulate the Scheduler control from outside CSS 'interfernce' by wrapping it in a div with specific settings?
    Regards, Ian
  2. Ian
    Ian avatar
    129 posts
    Member since:
    Jun 2009

    Posted 08 Jul 2010 Link to this post

    Sorted my own problem. In case anybody else encounters the same issue, the problem was caused by a global CSS setting for the <p> tag.

    In the Scheduler's .rsHeader div (it sits directly above the .rsContent div), there's a <p> tag that includes Previous day and Next day links. The 'margin-bottom' rule was being overridden by settings in the page's global CSS file for the <p> tag. Adding the following rule to the scheduler CSS file fixed the issue in both IE and FF:

    div.RadScheduler_<skin> div.rsHeader p {
        margin-bottom:0 !important; }

    Regards, Ian
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Steven Fischer
    Steven Fischer avatar
    6 posts
    Member since:
    May 2006

    Posted 11 Aug 2010 Link to this post

    Thank you, this fix worked for me as well.
  5. Jani
    Jani avatar
    61 posts
    Member since:
    Jan 2008

    Posted 17 Feb 2012 Link to this post

    Similar issue here. The scheduler was clipped on the right side.

    Original style sheet:
    html, body, form
    {
      margin: 0;
    }

    Fixed style sheet:
    html, body, form
    {
      margin-top: 0;
      margin-left: 0;
      margin-right: 0;
    }

    [Edit]
    The key point is to remove the margin-bottom.
    [/Edit]

    Cheers,
    Jani
Back to Top