Run sample show TimeoutException

9 posts, 0 answers
  1. hvduc
    hvduc avatar
    33 posts
    Member since:
    Jun 2010

    Posted 21 Jul 2010 Link to this post

    I'm running WebUI Test Studio Q1 2010.
    When I click button Record, a new browser window showed. but it open a blank page instead of Intro.html. Record toolbar don't show too.
    a message box shows TimeoutException like the image I attached.
    anyway to fix this?

    I run winXP, vs 2010, IE 8
  2. Konstantin Petkov
    Admin
    Konstantin Petkov avatar
    1911 posts

    Posted 21 Jul 2010 Link to this post

    Hi hvduc,

    Thank you for sending the capture of the error.

    This is a problem connecting the recorder to the browser. Did you have an older version of the product installed before? The installer should take care of detecting the old version but it may not detect a too outdated version for example allowing installation of the new version side by side with the older. If so please uninstall both versions and install the new one only.

    Also make sure the IE add-ons are installed and running. If so you can try disabling the other add-ons except ours:

    • WebUI TestStudio Recorder
    • WebAii Test Execution Extension

    to check if there is no any conflict with another add-on. 'Discuss' Add On may need to remain enabled as well.

    Finally there is also another reason for such problem in XP we found recently. What we found is that the shortcut that launches the tool can somehow be set to start in compatibility mode.  Could you please check it and let us know if that is the case on your end as well? You get to it by right clicking on the shortcut and selecting Properties. The checkbox should be unchecked allowing it to run normally on XP. You can find a screenshot of the compatibility setting UI here.

    Sincerely yours,
    Konstantin Petkov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. hvduc
    hvduc avatar
    33 posts
    Member since:
    Jun 2010

    Posted 22 Jul 2010 Link to this post

    I've tried all solution found in this forum but nothing works.
    What shortcut are you talking about? I open sample by select Programs\Telerik\WebUI Test Studio 2010.1\Samples\WebUI Test Studio
    This shortcut hasn't Compatibility properties like your screenshot
  4. Cody
    Admin
    Cody avatar
    3360 posts

    Posted 23 Jul 2010 Link to this post

    Hi hvduc,

    I apologize we weren't clear enough regarding the shortcut. For the QA edition we're referring to the icon normally placed on your desktop you use (double click on) to launch QA edition. If you right click on that icon and select Properties you'll get the dialog shown in the screenshot. The General tab will be selected by default when the dialog opens. Click the Compatibility tab to open it. Please make sure the "Run this program in compatibility mode for" is unchecked.

    Looking back at your screenshot of the error, it appears you are actually running the Dev Edition? Is that correct? You posted this in the QA Edition forum so I'm not sure now which edition you are trying to use.

    If you are using the Dev edition, please be sure you are logged onto your computer with an account that is a member of the Administrator group. Dev Edition requires full administrator rights to be able to fully function.

    Greetings,
    Cody
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Cody
    Admin
    Cody avatar
    3360 posts

    Posted 27 Jul 2010 Link to this post

    Hi hvduc,

    Just wanted to touch base with you. Did you get this problem resolved? Do you need any further assistance with this?

    Best wishes,
    Cody
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. hvduc
    hvduc avatar
    33 posts
    Member since:
    Jun 2010

    Posted 27 Jul 2010 Link to this post

    Sorry for my mistake. I actually use Dev edition.
    Yesterday I tried install WebUI on 2 different PCs. None of these raised TimeoutException error like the one before.
    I reinstalled Window, VS 2010, WebUI on PC that got error but it still doesn't work.
    do you have other way?
  7. Cody
    Admin
    Cody avatar
    3360 posts

    Posted 28 Jul 2010 Link to this post

    Hi hvduc,

    Thank you for the clarification. It appeared you were referring to the QA Edition since you posted in the QA Edtion forum.

    Since you are actually using the Dev Edition, the one thing to try is to run Visual Studio as administrator. WebUi Test Studio requires administrator rights to be able to fully run correctly. To do this, right click on Visual Studio located in your Start Menu then select "Run as administrator". Let me know if this solves your problem. If it does we can permanently modify that shortcut link so that it always starts in Administrator mode.

    Kind regards,
    Cody
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. hvduc
    hvduc avatar
    33 posts
    Member since:
    Jun 2010

    Posted 02 Aug 2010 Link to this post

    Sorry for my late reply. My account is already in Admins group so I don't think it is reason.
    I installed Window 7 on that PC and WebUI ran properly.
    I think the problem lies in WinXP SP3
  9. Cody
    Admin
    Cody avatar
    3360 posts

    Posted 03 Aug 2010 Link to this post

    Hello hvduc,

    Thank you for letting us know!

    Best wishes,
    Cody
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top