Ribbonbar Load Xml Error

2 posts, 0 answers
  1. Yo
    Yo avatar
    13 posts
    Member since:
    Aug 2013

    Posted 04 Sep 2013 Link to this post

    I got a error when i try to Load a Xml String to a RibbonBar.
    Below that is my code.

    RadRibbonBar1.LoadXml("<RibbonBar Skin=""Windows7"">    <Tab Text=""Home"">      <Group Text=""New"" EnableLauncher=""True"">" _
                       & "<Button ImageUrl=""Images/rButton/New.png"" Size=""Large"" />      </Group>      <Group Text=""Edit"" EnableLauncher=""True""> " _
                       & "<Button ImageUrl=""Images/rButton/Open.png"" Size=""Large"" />     <Button ImageUrl=""Images/rButton/Save.png"" Size=""Large"" /> " _
                       & "<Button ImageUrl=""Images/rButton/SaveAs.png"" Size=""Large"" />      </Group>      <Group Text=""Exit"" EnableLauncher=""True""> " _
                       & "<Button ImageUrl=""Images/rButton/Document.png"" Size=""Large"" />      </Group>    </Tab>  </RibbonBar>")

  2. Shinu
    Shinu avatar
    17764 posts
    Member since:
    Mar 2007

    Posted 05 Sep 2013 Link to this post

    Hi Yo,

    Please have a look at the sample code I tried which works fine at my end.

    <telerik:RadRibbonBar ID="RadRibbonBar1" runat="server">

    protected void Page_Init(object sender, System.EventArgs e)
        RadRibbonBar1.LoadXml("<RibbonBar><ApplicationMenu Text='File'><ApplicationMenuItem Text='New'/></ApplicationMenu><Tab Text='Home'><Group Text='Clipboard' EnableLauncher='true'><Button Size='Medium' Text='Cut'/></Group></Tab></RibbonBar>");

  3. DevCraft R3 2016 release webinar banner
Back to Top