RESTAPI - Send HTTPS request

4 posts, 0 answers
  1. Ashish
    Ashish avatar
    3 posts
    Member since:
    Jun 2016

    Posted 13 Sep Link to this post

    Hello, 

    I am sending HTTPS request using REST, Web project which requires username and password. But unable to get the expected response. Below is the info.

    Request: GET,

    URL: https://abc.xyz.com/api/info/version

    I am not sure where to enter or where is the field for Username and Password so, I selected 'Authorization' from Headers and entered value (Value is basic Base64). 

    After sending request, I get attached response. 

    I added the cert in my trusted root but no luck. 

    Can you please help with it? What am I doing wrong or am I missing something?

    Thanks, 

    Ashish Thakkar

     

     

  2. Ashish
    Ashish avatar
    3 posts
    Member since:
    Jun 2016

    Posted 15 Sep Link to this post

    Hi, 

    Has someone came across to this problem? Or is anyone looking to this issue please reply. 

    Thanks,

    Ashish

  3. Kiril Stanoev
    Admin
    Kiril Stanoev avatar
    1511 posts

    Posted 16 Sep Link to this post

    Hello Ashish,

    Thank you for contacting us and sorry for the delayed reply. Everything seems to be ok the way you're adding the credentials. My assumption is there is something wrong with the self-signed certificate. Could you please share more details on the process of adding your certificate. I'd be glad to assist you further.

    Regards,
    Kiril Stanoev
    Telerik by Progress
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
  4. Ashish
    Ashish avatar
    3 posts
    Member since:
    Jun 2016

    Posted 16 Sep in reply to Kiril Stanoev Link to this post

    Hi Kiril,

    I am able to successfully send HTTPS requests. Yes, there was a problem with my certificates. I added them you my Trusted cert list and it's working now.

    Thanks for your help!!

    Regards,

    Ashish

Back to Top