Report outside the App_Code folder not working

2 posts, 0 answers
  1. lamees
    lamees avatar
    56 posts
    Member since:
    Jul 2006

    Posted 16 May 2007 Link to this post

    Hello all,
               I'm a new user to the RadReporting Suite. I created a telerik report and put it on the App_Code folder and when i right click the CS file i can see the View Designer link. The problem is when i tried to create another one and put in in another folder the View Designer link doesn't show up !!!. Is there anyway that make me able to put the Report outside the App_code folder and to be able to view Designer form??
    Thanks in advance.
  2. Ivan
    Ivan avatar
    519 posts

    Posted 17 May 2007 Link to this post

    Hello metsie,

    For a Web Site project all code files should reside in the App_Code folder - otherwise they will be treated just as ordinary files and will not get compiled. Once you put your report code file in the App_Code folder, Microsoft Visual Studio will respects its designer and you'll have the View Designer option enabled.

    The other solution is to use the good old Web Application project (in order to have the Web Application project in VS2005 you should install Visual Studio Service Pack 1).

    If you want to keep some Report files inside the Web Site project but outside App_Code folder just drag these files into App_Code folder any time you want to use Telerik's Reporting Designer to design them.

    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. DevCraft banner
Back to Top