Rendering is delayed

6 posts, 0 answers
  1. Henrik Brinch
    Henrik Brinch avatar
    100 posts
    Member since:
    Aug 2004

    Posted 13 Apr 2008 Link to this post

    When having an input control on a page, it seems as it is rendered as one of the last things in the rendering process.  That is it seems as if it is rendered with a "standard look" and when the page is finished loading suddenly it changes to the skin selected.   This doesn't look very good, as it in some cases also resizes in the final rendering step.

    I'm using IE7.
  2. Vlad
    Admin
    Vlad avatar
    11100 posts

    Posted 15 Apr 2008 Link to this post

    Hi Henrik,

    Can you please verify if you have runat="server" attribute for the <head> tag? If this is missing the input css will be applied when the client-side object is created which will cause such delay.

    All the best,
    Vlad
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Henrik Brinch
    Henrik Brinch avatar
    100 posts
    Member since:
    Aug 2004

    Posted 17 Apr 2008 Link to this post

    Hereby verified, that the <head> tag har "runat=server".  The head tag resides on a masterpage and the controls on the content pages.

    I will verify if the "delay" problem still exists in the new version of the Rad suite.
  5. Sebastian
    Admin
    Sebastian avatar
    9934 posts

    Posted 17 Apr 2008 Link to this post

    Hi Henrik,

    Let us know how it goes after you finish the upgrade process to the new Q1 2008 release of RadControls.

    Best regards,
    Stephen
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  6. Henrik Brinch
    Henrik Brinch avatar
    100 posts
    Member since:
    Aug 2004

    Posted 17 Apr 2008 Link to this post

    I can now verify that I can't reproduce with the newest version.

    However, I just tried the RadFormDecorator ... which does have that delay.  E.g. a button is initially shown with the default look and when the page is finished loading it changes to the selected skin.  I know I should raise this question in FormDecorator thread ... but I guess the issue is the same.
  7. Martin
    Admin
    Martin avatar
    585 posts

    Posted 22 Apr 2008 Link to this post

    Hi Henrik Brinch,

    RadFormDecorator is still in development, and we are aware of the delay with input skinning. Currently we cannot provide a solution with this, but the problem will be solved in the near future.

    Sincerely yours,
    Martin Ivanov
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017