Reforce reload with showExternalDialog

4 posts, 1 answers
  1. ManniAT
    ManniAT avatar
    877 posts
    Member since:
    Nov 2003

    Posted 29 Apr 2009 Link to this post

    Hi,

    I use showExternalDialog. This works fine but I have 2 problems.

    I can't find a parameter to set "ReloadOnShow" - my dialog uses Databinding - and therefore it has to be reloaded at every call.
    I can't find a paramter to set the initial position - my Window is a bit large so I want to set the initial position to 10,10 or such a value.

    I'm sure you have an idea how to enable those two things.

    Regards

    Manfred
  2. ManniAT
    ManniAT avatar
    877 posts
    Member since:
    Nov 2003

    Posted 29 Apr 2009 Link to this post

    Hi,

    I solved the second problem by calling moveTo in InitDialog.
    But another problem came up - the z-index.
    I've seen this thread http://www.telerik.com/community/forums/aspnet-ajax/window/radmenu-still-active-with-a-modal-radwindow.aspx
    But - I have neither a WindowManger in this case - nor am I able to lower my menues z-Index because it has to be displayed of other controls on my page.

    Any idea about this?

    Regards

    Manfred
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Answer
    Lini
    Admin
    Lini avatar
    2144 posts

    Posted 04 May 2009 Link to this post

    Hello Manfred,

    For the first problem - you can reload the dialog each time by adding a random querystring parameter at the end of the URL. The dialog opener uses the URL to recognize the dialog, so if it changes, the dialog window will be refreshed.

    Best wishes,
    Lini
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  5. ManniAT
    ManniAT avatar
    877 posts
    Member since:
    Nov 2003

    Posted 04 May 2009 Link to this post

    Thank you Lini,

    I guess I'll do this with some datetime or random java code in the command handler.

    Regards

    Manfred
Back to Top