RedCaptcha doesn't appear on mobile

3 posts, 1 answers
  1. Igor
    Igor avatar
    2 posts
    Member since:
    Jan 2016

    Posted 27 Jan Link to this post

    I am using RedCaptcha on registration page and it works ok, but if i open this page from mobile device (or emulating it in browser) the redcaptcha image doesn't appear. If i open link from captcha src="" attribute in new tab i see the image.

    You can see this issue by this url: 
    https://demo.provantportalstaging.com/_layouts/15/Provant.CustomerPortal.Authentication/Participant%20Pages/Registration.aspx

    Maybe you have faced such issue earlier. 
    Any help will be appreciated

  2. Answer
    Marin Bratanov
    Admin
    Marin Bratanov avatar
    3595 posts

    Posted 01 Feb Link to this post

    Hi Igor,

    When anonymous access (http://blog.cloudshare.com/2012/10/15/how-to-enable-anonymous-access-to-a-sharepoint-2013-site) is enabled and the page is viewed from a mobile browser, the HttpHandler that serves the captcha image should be requested in a folder that can be accessed by anonymous users. If the HttpHandler is not configured, the image will not appear.

    You should open the page with the captcha and use the HttpHandlerUrl property of the control to configure it to request Telerik.Web.UI.WebResource.axd in a folder that is accessible, for example _layouts: 

    <telerik:RadCaptcha ID="RadCaptcha1" Runat="server" ForeColor="Red"
     ErrorMessage="You have entered an invalid code." HttpHandlerUrl="~/_layouts/Telerik.Web.UI.WebResource.axd">
    </telerik:RadCaptcha>


    Regards,

    Marin Bratanov
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Igor
    Igor avatar
    2 posts
    Member since:
    Jan 2016

    Posted 01 Feb in reply to Marin Bratanov Link to this post

    HttpHandlerUrl="~/_layouts/Telerik.Web.UI.WebResource.axd" solved my problem.

     Thank you, Marin!

Back to Top