Red X with RadChart

Thread is closed for posting
17 posts, 0 answers
  1. Big Daftie
    Big Daftie avatar
    7 posts
    Member since:
    Jun 2008

    Posted 17 Jun 2008 Link to this post

    Hello there,

    I am new to RadControls and RadChart - however I have a problem with the RadChart control - whenever I view my page with the chart on it via VWD 2008 web server, it appears fine. However when I then view the web page with an internet browser (outside of VWD, via the PCs IP Address), I get a red 'X' where the graph should be!

    If I disable UseSession, the charts are generated and stored in ~/Temp (as configured), however I still get a Red 'X' if I try to view the chart on the webpage?

    Can anyone help?
  2. Ves
    Admin
    Ves avatar
    2879 posts

    Posted 17 Jun 2008 Link to this post

    Hello Big Daftie,

    Please, check to see if you have registered the correct version of the HTTP Handler in your Web.Config or add an HTTP Handler through the smart tag during design-time as shown here.

    Regards,
    Ves
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Big Daftie
    Big Daftie avatar
    7 posts
    Member since:
    Jun 2008

    Posted 17 Jun 2008 Link to this post

    Hi there Ves,

    Thank you for such a quick reply - yes I registered the HTTP Handler via the smart tag option on the control - it does appear in the web.config.

    As I say, the control works correctly using the internal web server for VWD. If the handler was not registered properly, would it not fail to operate under this scenario?
  5. Ves
    Admin
    Ves avatar
    2879 posts

    Posted 17 Jun 2008 Link to this post

    Hi Big Daftie,

    Do you use Vista by any chance? Could you confirm whether your website is run under IIS7 Integrated mode? In this case the web server searches the HttpHandler registrations under the <system.webServer> configuration section instead of the standard <system.web> configuration section of the application configuration file.

    As Visual Studio 2005 currently does not support the <system.webServer> section, it is needed to register the RadControls “Prometheus HttpHandlers manually like this:

    Let’s suppose you have the following structure of the web.config file:

    <system.web>

          <httpHandlers>

                  

    <add path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI" validate="false" />

               

          </httpHandlers>

    </system.web>

    <system.webServer>

          <handlers>

               

          </handlers>

    </system.webServer>

    All you need to do to manually register the HttpHandler for the IIS7 Integrated mode is copy the Telerik HttpHandler to the <handlers> section of the <system.webServer> section group, delete the validate attribute and give it a name, e.g.:

    <system.webServer>

          <handlers>

               

    <add name=”ChartHandler” path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI" />

               

          </handlers>

    </system.webServer>


    Hope this helps.

    Regards,
    Ves
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  6. Big Daftie
    Big Daftie avatar
    7 posts
    Member since:
    Jun 2008

    Posted 17 Jun 2008 Link to this post

    Hi there Ves,

    I am indeed using Vista - and your solution has sorted the problem! Thank you very much for your help on this - very much appreciated.

    Thanks!
  7. Patrick Barranis
    Patrick Barranis avatar
    68 posts
    Member since:
    Jul 2009

    Posted 04 Oct 2009 Link to this post

    I'm having the same problem Big Daftie had, and I can't seem to get rid of it.  My development environment is on Win 7, VS 2008, .NET 3.5, SQL 2008, and I'm using the VS Intgrated Web Hosting... doohicky :).  On the development machine, all is well.  It's a "Web App" (migrated from old days), and the HttpHandler section is included ala IIS6 / "Classic Pipeline".

    My web server is where the problem is.  I'm trying to deploy the site to a staging server, and in IIS7 with Integrated Pipeline I just can't get the exact error Big Daftie mentioned to go away.  Here's my Handlers section:
            <handlers> 
                <add name="ChartHandler" path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI" /> 
                <add name="fetchzip.axd_*" path="fetchzip.axd" verb="*" type="MUTI.SITE.Website.FetchZipItemHandler" preCondition="integratedMode,runtimeVersionv2.0" /> 
                <add name="fetch.axd_*" path="fetch.axd" verb="*" type="MUTI.SITE.Website.FetchItemHandler" preCondition="integratedMode,runtimeVersionv2.0" /> 
            </handlers> 
     

    After fighting trying to figure it out, I decided to make a copy of the website running with the Classic Pipeline.  I copied everything out of the other website into a new folder, created a new site in IIS, and set the app pool for it to Classic Pipeline.  Then I put in the old-style handlers in:
            <httpHandlers>    
                <add path="fetch.axd" verb="*" type="MUTI.SITE.Website.FetchItemHandler"/>     
                <add path="fetchzip.axd" verb="*" type="MUTI.SITE.Website.FetchZipItemHandler"/>     
                <add path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI, Version=2009.2.826.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4" validate="false" />    
            </httpHandlers>  

    And, of course, everything worked fine in the latter case.  Also, I know the "type=" setting is different right now, but I did try copying the long-hand assembly name into the one for Integrated Pipeline, and that didn't work either.  I'd really appreciate any help - this is driving me nuts and I'm under a deadline!  Thanks!

    Patrick
  8. Ves
    Admin
    Ves avatar
    2879 posts

    Posted 05 Oct 2009 Link to this post

    Hi Patrick,

    The issue seems to be caused by the assembly name in the http handler registration:

    <add name="ChartHandler" path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI" />
               
    Please, remove it so that the line looks like this:

    <add name="ChartHandler" path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler" />
               

    Best regards,
    Ves
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  9. Patrick Barranis
    Patrick Barranis avatar
    68 posts
    Member since:
    Jul 2009

    Posted 05 Oct 2009 Link to this post

    Unfortunately, that didn't do the trick.  I deleted the line from the web.config and copy/pasted your text verbatim and it still didn't work.

    I did notice that if I go into the IIS GUI, into Handler Mappings, and then open the handler named ChartHandler and look in the drop-down for Type... there are several that start with Telerik.Web.UI, but the specific one we're supposed to be using is missing.  Is that supposed to be the case?

    Thanks,
    Patrick
  10. Ves
    Admin
    Ves avatar
    2879 posts

    Posted 06 Oct 2009 Link to this post

    Hi Patrick,

    Indeed, it is strange that the ChartHttpHandler does not appear in the Type dropdown. I have notified our developers of this. Still, it is possible to register it, please refer to the image I have attached. It produced the following line in my web.config file:

    <add name="ChartHandler" path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler" resourceType="Unspecified" preCondition="integratedMode" />

    Then, I was able to remove the resourceType and preCondition attributes, which makes it virtually the same line as the one from my previous message, and the chart was still working fine.

    If the above still does not work, there is one last hint -- let the chart register the httphandler for you. Remove both httphandler registrations from web.config and save it. Then open the page, containing RadChart in design view and use the "Add RadChart HTTP handler to web.config" link in the control smart tag.

    Sincerely,
    Ves
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  11. Patrick Barranis
    Patrick Barranis avatar
    68 posts
    Member since:
    Jul 2009

    Posted 06 Oct 2009 Link to this post

    Unfortunately, that first idea didn't do the trick either.  I inputted the handler through the IIS GUI and then edited it after, as you said, and it still didn't work.

    However, this is in production/staging (no dev tools on the server), so I can't do the second thing - letting the the Chart add its own handler "automagically".  That's exactly what I did in development on my machine, and it worked fine, but not on the server.

    What do I try next?  Unfortuantely I'm sort of on a deadline to get this app past Microsoft's Server 2008 Logo Testing...

    I had been using the demo version of the controls, but yesterday I finally bought the Premium Suite.  I'm in the process of running the installer now, and I'll copy over the production DLLs to the server as soon as they're installed on my workstation.  Maybe that will help?

    I'll look forward to more suggestions.

    Thanks,
    Patrick
  12. Patrick Barranis
    Patrick Barranis avatar
    68 posts
    Member since:
    Jul 2009

    Posted 06 Oct 2009 Link to this post

    No luck using the paid DLLs either.  I rebuilt and recopied all the files.  The site running Classic Pipeline still works fine and the site with the new, Integrated Pipeline still fails with a red X and an error message.

    Patrick
  13. Ves
    Admin
    Ves avatar
    2879 posts

    Posted 07 Oct 2009 Link to this post

    Hi Patrick,

    Trial / dev dll's should not make any difference in this case, The trial assemblies are fully functional. This issue might appear in a load-balanced environment as it is possible that the page and the httphandler are served by different machines, so the image is not found. However, in such case, the error appears randomly as it is possible that the same machine gets both requests. As I understand, the problem appears all the time. Is that correct? Still, if this is the case -- you may consider implementing sticky session or state server session state.

    Another possible cause would be an URL rewriter. In this case, the http handler request might not be the correct one. You can check this forum post for more details.

    Best regards,
    Ves
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  14. Patrick Barranis
    Patrick Barranis avatar
    68 posts
    Member since:
    Jul 2009

    Posted 07 Oct 2009 Link to this post

    In quick form:
    * No load balancing.
    * Error appears every time.
    * In-proc session state is active.
    * No DNN installed.  No URL rewriting.

    This is a pretty vanilla install of Windows Server 2008 Enterprise x64 upgraded to R2 with SQL 2008 Developer installed.  It's just a virtual machine I had sitting around, formatted and having never been used.  I did not install Telerik controls on it; I just copied the Telerik.Web.UI.dll from the dev machine into the bin folder on the staging server. 

    Also, the site is a Web App, not Web Site, upgraded from .NET 1.1 to .NET 2 to .NET 3.5 over the years.  Any known issues with Web Apps, IIS7, Integrated Pipeline, and Telerik RadChart?

    Thanks,
    Patrick
  15. Ves
    Admin
    Ves avatar
    2879 posts

    Posted 08 Oct 2009 Link to this post

    Hi Patrick,

    I am afraid we are not aware of such issues with RadChart and all the reports we have had so far have been resolved with correct http handler registration. Can you please create a simple web application on your dev station and register the http handler using the link in the smart tag. Then deploy it to the server and check if it works fine.

    You can also use fiddler or firebug to check the result of the request to ChartImage.axd and whether the url is the expected one - if the page is http://myapp/default.aspx, the chart handler should be at http://myapp/chartimage.axd.

    Best regards,
    Ves
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  16. Mark
    Mark avatar
    79 posts
    Member since:
    Apr 2007

    Posted 09 Jan 2010 Link to this post

    I was looking for this topic all day, thanks!

    Added this:

    <add name="ChartHandler" path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI" /> 

    To my system.webServer section in web.config and I'm good to go.
  17. <span>w</span>
    <span>w</span> avatar
    84 posts
    Member since:
    Jun 2012

    Posted 23 Jul 2013 Link to this post

    Not work for me. Can you please help me in this?

    enter image description here
  18. <span>w</span>
    <span>w</span> avatar
    84 posts
    Member since:
    Jun 2012

    Posted 23 Jul 2013 Link to this post

    This problem has been solved by adding some line in web.config.

    Let say my path:
    test.com/Checking/Ck/index.aspx

     I added that line in web.config.
      <location path="Checking/Controls/ChartImage.axd">
        <system.web>
          <authorization>
            <allow users="*"/>
          </authorization>
        </system.web>
      </location>

    Hope such type of things help you in future.

    Muhammad Waseem,
    the Telerik team
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017