Radwindow Shifting on click of RadTabstrip tabs

6 posts, 0 answers
  1. Raj
    Raj avatar
    9 posts
    Member since:
    Oct 2007

    Posted 17 Dec 2008 Link to this post

    Hi Telerik Team,

    I am facing a problem with Rad window control. I have opened a Radwinow inside a RadTabsrip,Every time when I click on the  tabs the Radwindow keeps shifting upwords on the Tabs.

    Please suggest some solution ASAP.

    Thanks in Advance,
    Raj


  2. Georgi Tunev
    Admin
    Georgi Tunev avatar
    7207 posts

    Posted 17 Dec 2008 Link to this post

    Hi Raj,

    To be able to help you we need to have more information about your exact setup - the behavior that you report is most likely a result of a particular code that you are using.

    Please open a new support ticket and send us a small sample project that reproduces your setup and the problem - we will check it and do our best to help.



    Sincerely yours,
    Georgi Tunev
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. ZSN
    ZSN avatar
    6 posts
    Member since:
    Oct 2006

    Posted 21 Mar 2009 Link to this post

    I have the exact same problem. On a page that has a RadTab strip and I am using the RadWindow as container, just like in your samples.  There is a RestrictionZoneID set and all is well on the first tab click.

    Each time a click is done on any tab, the RadWindows move up and up with each click. IT eventually becomes unusable as the window covers all the tabs.

    I am following your demo exactly and copied the code as it is from this demo.

    http://demos.telerik.com/aspnet-ajax/window/examples/radwindowandmdi/defaultcs.aspx

    I am using the latest update as of 3/18 2009 for the controls.

    Thanks.
  5. ZSN
    ZSN avatar
    6 posts
    Member since:
    Oct 2006

    Posted 21 Mar 2009 Link to this post

    I did a retest and interestingly it happens in IE 8. If i use the Compatibilty mode, or IE 7, it works fine.
  6. ZSN
    ZSN avatar
    6 posts
    Member since:
    Oct 2006

    Posted 21 Mar 2009 Link to this post

    So I see that you have fixed your demos to run only in IE 7 compatibiltiy mode on the demos.

    <
    meta http-equiv="X-UA-Compatible" content="IE=7" />

    That explains why it works on your demos.

  7. Georgi Tunev
    Admin
    Georgi Tunev avatar
    7207 posts

    Posted 23 Mar 2009 Link to this post

    Hello ZSN,

    Yes, we are familiar with this issue and we are currently working on a service pack that will provide full compatibility for RadControls for ASP.NET AJAX Q1 2009 with the official version of IE. The service pack will appear in 2 weeks.


    Kind regards,
    Georgi Tunev
    the Telerik team

    Check out Telerik Trainer , the state of the art learning tool for Telerik products.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017