RadUpload not showing after upload to IIS

Thread is closed for posting
3 posts, 0 answers
  1. arijit
    arijit avatar
    49 posts
    Member since:
    Jun 2012

    Posted 20 Mar 2012 Link to this post

    Hi everything is working when I run locally.
    But RadUpload not showing after upload to IIS, i am using asp.net 4.0, IIS 7

    My web config
    <?xml version="1.0"?>
    <!--
      For more information on how to configure your ASP.NET application, please visit
      -->
    <configuration>
      <connectionStrings>
        <add name="ApplicationServices" connectionString="data source=.\SQLEXPRESS;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|\aspnetdb.mdf;User Instance=true" providerName="System.Data.SqlClient" />
        <add name="DB" connectionString="server=.;user id=sa;password=sa123!;database=AspNetHelper" providerName="System.Data.SqlClient" />
      </connectionStrings>
      <appSettings>
        <add key="SiteAddress" value="http://localhost:9339/" />
         <add key="ImagePath" value="c:\AspNetHelperImage"/>
        <add key="ProjectFile" value="C:\AspNetHelperProjectFile" />
      </appSettings
     
      <system.web>
        <compilation debug="true" targetFramework="4.0" />
        <trust level="Full" originUrl="" />
        <httpRuntime
        executionTimeout="90"
        maxRequestLength="4096000"
        useFullyQualifiedRedirectUrl="false"
        minFreeThreads="8"
        minLocalRequestFreeThreads="4"
        appRequestQueueLimit="100"
        enableVersionHeader="true"
        />
         <httpModules>
          <add name="RadUploadModule" type="Telerik.Web.UI.RadUploadHttpModule" />
        </httpModules>
     
        <httpHandlers>
          <add path="Telerik.Web.UI.WebResource.axd" verb="*" type="Telerik.Web.UI.WebResource" validate="false" />
          <add path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" validate="false" />
         <add path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.RadUploadProgressHandler" verb="*" validate="false" />
       </httpHandlers>
        <authentication mode="Forms">
          <forms loginUrl="~/Account/Login.aspx" timeout="2880" />
        </authentication>
        <membership>
          <providers>
            <clear/>
            <add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="ApplicationServices" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="false" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" applicationName="/" />
          </providers>
        </membership>
        <profile>
          <providers>
            <clear/>
            <add name="AspNetSqlProfileProvider" type="System.Web.Profile.SqlProfileProvider" connectionStringName="ApplicationServices" applicationName="/" />
          </providers>
        </profile>
        <roleManager enabled="false">
          <providers>
            <clear/>
            <add name="AspNetSqlRoleProvider" type="System.Web.Security.SqlRoleProvider" connectionStringName="ApplicationServices" applicationName="/" />
            <add name="AspNetWindowsTokenRoleProvider" type="System.Web.Security.WindowsTokenRoleProvider" applicationName="/" />
          </providers>
        </roleManager>
    <customErrors mode="Off" defaultRedirect="GenericErrorPage.htm">
                <error statusCode="403" redirect="NoAccess.htm" />
                <error statusCode="404" redirect="FileNotFound.htm" />
            </customErrors>
        <pages theme="BlueTheme">
        </pages>
      </system.web>
      <system.webServer>
        <modules runAllManagedModulesForAllRequests="true" />
        <validation validateIntegratedModeConfiguration="false" />
         
         
        <handlers>
          <add name="Telerik.Web.UI.WebResource.axd*" path="Telerik.Web.UI.WebResource.axd" verb="*" type="Telerik.Web.UI.WebResource" />
          <add name="Telerik_Web_UI_SpellCheckHandler_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" />
          <add name="Telerik.RadUploadProgressHandler.ashx_*" path="Telerik.RadUploadProgressHandler.ashx" verb="*" type="Telerik.Web.UI.RadUploadProgressHandler" />
      </handlers>
      </system.webServer>
    </configuration>

    aspx page is
    <telerik:RadProgressManager ID="Radprogressmanager1" runat="server"  />
     
     Project File
    <input type="file" id="file1" runat="server" name="file1" />
    <telerik:RadProgressArea ID="progressArea1" runat="server" Skin="Office2007"
    Language=""  />

    Please help
    Arijit Chatterjee
  2. Dimitar Terziev
    Admin
    Dimitar Terziev avatar
    1266 posts

    Posted 23 Mar 2012 Link to this post

    Hi,

    After inspecting the mark-up provide I've noticed that there is no RadUpload, but you are using input type file instead. In case you are really using the RadUpload control try to add the following lines to your web config file:
    <location path="Telerik.Web.UI.WebResource.axd">  
        <system.web>      
            <authorization>
                <allow users="*" />      
            </authorization>  
        </system.web>
    </location>


    All the best,
    Dimitar Terziev
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Mohammad
    Mohammad avatar
    13 posts
    Member since:
    Dec 2012

    Posted 29 Apr 2013 Link to this post

    did you manage to fix the issue ?! the control in radGRID  edit template ,, over sharepoint 2010 .NET framwork 3.5 ..
    its working find when i remove the ajax update panel ,, but when i add the control to RadAjaxManager or updatepanel ,, its does not appear.. 
Back to Top