RadTreeView Drag and Drop Auto Scroll No Longer Working in 2010 Q3

6 posts, 0 answers
  1. Matthew Cartwright
    Matthew Cartwright avatar
    31 posts
    Member since:
    Oct 2005

    Posted 29 Nov 2010 Link to this post

    We have a view with a RadGrid --> RadTreeView drag and drop function. Up to 2010 Q2 the auto scroll was working OK. With the default upgrade to 2010 Q3 our implementation of drag and drop has stopped working. 

    I know that the drag and drop auto scroll is working for 2010 Q3 in a simple scenario and this problem is related to our implementation.

    So, has anyone else seen this and identified the culprit?
    Where is the Auto Scroll code implemented? What are likely candidates to cause this to start failing?
    What is the best approach to debug and identify the cause?

    Note: (I have already tried both taking a simple repro and adding complexity - the auto-scroll is always working. Also  created a copy of our implementation and removed the complexity - the auto-scroll is never working.

    Thanks,
  2. Tina Stancheva
    Admin
    Tina Stancheva avatar
    3298 posts

    Posted 29 Nov 2010 Link to this post

    Hello Matthew Cartwright,

    Actually there was a known issue with the DragDrop AutoScroll feature of the RadTreeView introduced with the Q3 2010 official release. However, it is already fixed and I wanted to ask you to test it with the latest internal build and let me know if it works for you. Thank you in advance.

    Greetings,
    Tina Stancheva
    the Telerik team
    Browse the videos here>> to help you get started with RadControls for Silverlight
  3. DevCraft banner
  4. Matthew Cartwright
    Matthew Cartwright avatar
    31 posts
    Member since:
    Oct 2005

    Posted 30 Nov 2010 Link to this post

    I am reluctant to take an internal build into our production code. Can you provide more details on the problem and alternative work arounds?

    Thanks,
  5. Tsvyatko
    Admin
    Tsvyatko avatar
    833 posts

    Posted 30 Nov 2010 Link to this post

    Hello Matthew Cartwright,

    In the attached project (containing the implementation of highlight zones using the official release) I have implemented custom AutoScroll option. You can also check this blog post - http://blogs.telerik.com/kirilstanoev/posts/10-11-25/how_to_implement_autoscroll_while_dragging_in_radtreeview.aspx for simplified version of autoscroll as well.
     Let me know if this fits in your scenario.

    Regards,
    Tsvyatko
    the Telerik team
    Browse the videos here>> to help you get started with RadControls for Silverlight
  6. Matthew Cartwright
    Matthew Cartwright avatar
    31 posts
    Member since:
    Oct 2005

    Posted 30 Nov 2010 Link to this post

    Will this be a permanent replacement for the existing auto-scroll feature in the RadTreeView, or just a workaround whilst the current bug is worked out?
  7. Tsvyatko
    Admin
    Tsvyatko avatar
    833 posts

    Posted 01 Dec 2010 Link to this post

    Hi Matthew Cartwright,

    We considered this issue as bug which is already resolved is available in our latest internal build as well as in our upcoming service pack - later this year.

    The provided samples offer custom solution to the problem mentioned above. However, it can be used with the service pack as well and will no interfere with the default autoscroll functionality.

    If you have any further questions do not hesitate to contact us.


    Greetings,
    Tsvyatko
    the Telerik team
    Browse the videos here>> to help you get started with RadControls for Silverlight
Back to Top
DevCraft banner