RadToolTip fires when back button is used

2 posts, 0 answers
  1. Pat O'Neil
    Pat O'Neil avatar
    7 posts
    Member since:
    Jul 2009

    Posted 08 Jun 2010 Link to this post

    We have a RadToolTip that opens up some news items on our site, everything works fine as far as opening and closing it but the problem happens when the tooltip gets closed and the user goes to another page and then hits the back button.  The ToolTip then fires on that page load.  Is there an easy way to stop that?
  2. Svetlina Anati
    Svetlina Anati avatar
    2795 posts

    Posted 14 Jun 2010 Link to this post

    Hi Pat O'Neil,

    Basically, when you hit the Back button the page is again loaded from the cache and we do not have control on this. However, the tooltip should not show in case you have closed it before redirecting to the other page. I tested the scenario and I also tested the scenario with not closed tooltip but in all cases the tooltip did not show again. That is why I will really need to examine some test setup - could you please
    open a new support ticket and send us a sample, fully runnable reproduction demo (no need for complex custom logic, database, etc - you can simply use hyperlinks and tooltip) along with detailed reproduction steps and a video capture of the reproduction taken from the very same demo if possible and once we are able to examine the issue locally we will see what can be done.

    Best wishes,
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. DevCraft R3 2016 release webinar banner
Back to Top