RadThemeManager and Usercontrols

2 posts, 0 answers
  1. Sean McConnell
    Sean McConnell avatar
    38 posts
    Member since:
    Aug 2007

    Posted 04 Mar 2008 Link to this post

    Is it correct to place a theme-manager on a UserControl? I ask this because we have user controls that use Rad-Controls and the only way I could get the themes to apply is to put the thememanager on the Usercontrol itself - there is no 'form' when editing the controls.

    This does work, however, when I make changes to the theme (via VSB or directly in xml) they are not applied. I have to REMOVE the reference to the embedded resource, and add it again - then the theme changes are working.

    I noticed on a regular form I do not have to do this.

    Any thoughts on this issue?
  2. Nikolay
    Admin
    Nikolay avatar
    1803 posts

    Posted 06 Mar 2008 Link to this post

    Hi Randall Kohltfarber,

    A likely cause of the behavior you experience is that you are editing the original theme file, but not the one that is copied in the project directory.

    Generally, when you add a theme as a resource, a local project copy is created from the original file. After this happens, the project only references that copy. I tried modifying the local copy, then Rebuilt the project and the changes were taken into consideration both at design and run-time.

    If you have additional questions, do not hesitate to contact me.

    All the best,
    Nikolay
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. UI for WinForms is Visual Studio 2017 Ready
Back to Top