RadSpell Language in sharepoint

10 posts, 0 answers
  1. edgar.cardeira
    edgar.cardeira avatar
    4 posts
    Member since:
    Jul 2007

    Posted 14 Nov 2008 Link to this post

    Sorry, but i can't find in the Help how to configure languages in radSpell in sharepoint. I want to spell check two languages.
    so i supose it should be in the control or in the config xml.
    Can you help me?

    Thanks,
    Edgar Cardeira
  2. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 17 Nov 2008 Link to this post

    Hi Edgar,

    To enable multi-language spellchecking you should modify the ToolsFile.xml / ListToolsFile.xml files of Telerik RadEditor.  You need to add the multi-language definition, along with the languages you need to appear in the dropdown:

    <languages>
      <language code="en-US" title="English"></language>
      <language code="fr-FR" title="French"></language>
    </languages>


    Best regards,
    Rumen
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Janec
    Janec avatar
    3 posts
    Member since:
    Sep 2007

    Posted 26 Mar 2009 Link to this post

    Hello,

    I'm trying to add the multilingual spell check to the listToolsFile.xml 
    an abstract:"
      <tool separator="true" />
        <tool name="SpellCheck"/>
        <tool separator="true" />
        <tool name="Help" shortcut="F1" />
      </tools>
      <contextMenus>
        <contextMenu forElement="*">
          <tool name="Cut"/>
          <tool name="Copy"/>
          <tool name="Paste"/>
        </contextMenu>
      </contextMenus>
      <Languages>
          <language code="nl-NL" title="Nederlands"/>
          <language code="fr-FR" title="Français"/>
      </Languages>

    Until now I haven't  been succesfull in doing this. Can you help? And what do you mean with: add the multi-language definition?

    Thanks in advance,

    Janec
  5. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 31 Mar 2009 Link to this post

    Hi Janec,

    Please, replace the SpellCheck tool with the AjaxSpellCheck tool and also change the languages tag to start with lowercase L letter, e.g.

    <root>
      <tools>
      <tool separator="true" />
      <tool name="AjaxSpellCheck"/>
      <tool separator="true" />
      <tool name="Help" shortcut="F1" />
      </tools>
      <contextMenus>
        <contextMenu forElement="*">
          <tool name="Cut"/>
          <tool name="Copy"/>
          <tool name="Paste"/>
        </contextMenu>
      </contextMenus>
      <languages>
        <language code="nl-NL" title="Nederlands"/>
        <language code="fr-FR" title="Français"/>
      </languages>
    </root>

    You should also put the nl-NL.tdf dictionary in the \Program Files\Common Files\Microsoft Shared\web server extensions\wpresources\RadEditorSharePoint\5.x.x.x__1f131a624888eeed\Resources\App_Data\RadSpell folder

    This should enable the multilingual AjaxSpelllChecker dropdown.

    All the best,
    Rumen
    the Telerik team

    Check out Telerik Trainer , the state of the art learning tool for Telerik products.
  6. Janec
    Janec avatar
    3 posts
    Member since:
    Sep 2007

    Posted 21 Apr 2009 Link to this post

    Thanks a lot.

    But my tdf's are not in the same folder apparently. Mine are in : C:\Program Files\Common Files\Microsoft Shared\web server extensions\wpresources\RadEditorSharePoint\4.5.4.0__1f131a624888eeed\RadControls\Spell\TDF

    Could this be the game breaker?
  7. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 24 Apr 2009 Link to this post

    Hi,

    You have specified that you are using version 2008.3 1105 of RadSpell for ASP.NET AJAX, but in the provided link for the TDF folder I noticed that you are using version 4.5.4 of RadEditor for MOSS, which uses the classic versions of RadEditor and RadSpell. The classic controls use theRadControls folder to store their dialog files, tdf dictionaries, skins, etc and indeed you should put the nl-NL.tdf dictionary file in the

    C:\Program Files\Common Files\Microsoft Shared\web server extensions\wpresources\RadEditorSharePoint\4.5.4.0__1f131a624888eeed\RadControls\Spell\TDF

    folder. Please, try this on your side and let me know if you still experience the problem.

    Best regards,
    Rumen
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  8. Janec
    Janec avatar
    3 posts
    Member since:
    Sep 2007

    Posted 05 May 2009 Link to this post

    I 've got it running now. Thanks
  9. PeteV
    PeteV avatar
    3 posts
    Member since:
    Dec 2006

    Posted 10 May 2011 Link to this post

    Hi,

    I am trying spell check in English UK only.

    I have specified the language as en-GB and have the right tdf file etc.

    Is it possible that it doesn't show the drop down as I only have one language? Can it be set that en-GB is the default language?

    Thanks in advance
    Peter
  10. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 12 May 2011 Link to this post

    Hi Janec,

    To enable the en-GB spellchecking you should not only copy the tdf dictionary in the App_Data/RadSpell folder, but also set the SpellDictionaryLanguage property to en-GB in the ConfigFile.xml / ListConfigFile.xml of RadEditor for SharePoint.

    The following help article shows how to set properties in the config file of RadEditor for SharePoint 2010:
    http://www.telerik.com/help/aspnet-ajax/moss-sp2010-set-properties-via-config-file.html


    Regards,
    Rumen
    the Telerik team

    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.

  11. PeteV
    PeteV avatar
    3 posts
    Member since:
    Dec 2006

    Posted 18 May 2011 Link to this post

    Hi Janec,

    Thanks for the response. All is working as expected.

    Thanks again
    Peter
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017