Radschedular Alignment issue

11 posts, 1 answers
  1. Ruby
    Ruby avatar
    23 posts
    Member since:
    Mar 2012

    Posted 15 Jan 2014 Link to this post

    Hi, I have been using Radschedular for quiet some time. One of our business users reported that appointments are moving up on scroll. Like if  an appointment is schedule for 9pm, it is moving up to 8:45pm.
    My radschedular code is :

     

     

    <telerik:RadScheduler runat="server" ID="RadScheduler1" Skin="Outlook" Height="630px"

     

     

     

    WorkDayStartTime="06:00:00" WorkDayEndTime="22:00:00" DayStartTime="06:00:00"

     

     

     

    DayEndTime="22:00:00" TimeZoneOffset="00:00:00" DataKeyField="REP_APPT_ID" DataSubjectField="Subject"

     

     

     

    CustomAttributeNames="RECUR_SERIES_ID" DataStartField="START_DT_TIME" DataEndField="END_DT_TIME"

     

     

     

    AllowEdit="false" AllowInsert="false" ShowViewTabs="false"

     

     

     

    NumberOfHoveredRows="1" MinutesPerRow="15" TimeLabelRowSpan="2" HoursPanelTimeFormat="h:mm tt"

     

     

     

    AppointmentStyleMode="Default" OnClientAppointmentDoubleClick="OnClientAppointmentDoubleClick"

     

     

     

    OnClientTimeSlotClick="OnClientTimeSlotClick"

     

     

     

    AllowDelete="false" >

     

     

     

    </telerik:RadScheduler>

     


    I am attaching screenshot with the ticket. Any help would be appreciated.
  2. Ruby
    Ruby avatar
    23 posts
    Member since:
    Mar 2012

    Posted 16 Jan 2014 Link to this post

    There is an issue with Telerik Radschedular (Q3 version) . The horizontal scrollbar displays even if we dont want it. As soon as I changed my Telerik version to Q2 , RadScheular started working correctly. Please let us know when the issue is resolved. Thanks
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Kate
    Admin
    Kate avatar
    1898 posts

    Posted 20 Jan 2014 Link to this post

    Hello Ruby,

    I tested the issue that you are referring to with our on-line demo here but I was not able to replicate it. Do you get the scroll bar in a specific browser only? Do you have any other styles that you apply to the page and that might be causing the appearance that you get?

    Regards,
    Kate
    Telerik
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
  5. Ruby
    Ruby avatar
    23 posts
    Member since:
    Mar 2012

    Posted 21 Jan 2014 Link to this post

    Hi Kate,

    We are using IE 8 to run our current application. As I mentioned before with Q2 version, it is working normally (no extra horizontal scrollbar). I have tried changing the stylesheets but that doesn't make any difference. The css we applied   to the page is :

    .RadScheduler_Outlook .rsContent .rsHoursTable th
    {
        height: 16px;
    }

    .RadScheduler_Outlook .rsDayView td.rsCell
    {
        height: 16px;
    }

  6. Kate
    Admin
    Kate avatar
    1898 posts

    Posted 23 Jan 2014 Link to this post

    Hi Ruby,

    Thank you for the clarifications.

    I tested the code that you provided along with the styles and I am still not able to get the problematic appearance that you describe (I used the 2013.3.1114.40 version of the Telerik controls). Here is a short video demonstrating the behavior and the look that I get from my side. Let me know if you use any other version and if I am still missing something in your scenario.

    Regards,
    Kate
    Telerik
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
  7. Ruby
    Ruby avatar
    23 posts
    Member since:
    Mar 2012

    Posted 23 Jan 2014 Link to this post

    I tried a very simple example on different  IE versions, without css or code behind. I tried it on  IE tester tool and looks like Radschedular is showing scrollbar on verison 9 and 7 while no scrollbar with version 6 and 8. Please check this video, this video is on my localhost but it does the same on the production links
  8. Kate
    Admin
    Kate avatar
    1898 posts

    Posted 28 Jan 2014 Link to this post

    Hello Ruby,

    Thank you for getting back to me.

    After some further testing I was able to get the scrollbar that you describe in IE7 browser only. Please try adding the following css class selector and check if this is helpful in your scenario:
    div.rsContentScrollArea {
                overflow-x: hidden;
            }

    Let me know how it goes and if you have any further questions that I can assist you with.

    Regards,
    Kate
    Telerik
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the UI for ASP.NET AJAX, subscribe to the blog feed now.
  9. Ruby
    Ruby avatar
    23 posts
    Member since:
    Mar 2012

    Posted 28 Jan 2014 in reply to Kate Link to this post

    Hi Kate, thanks for your reply. I tried your code above and the issue is resolved for IE7 but I forgot to mention earlier that my application is running on compatibilty view currently (even in production). If i disable compatibilty view radscheduler is working correctly. But with compatibilty mode off the scrollbar is still showing up. Is there anything you could suggest?
  10. Ruby
    Ruby avatar
    23 posts
    Member since:
    Mar 2012

    Posted 28 Jan 2014 in reply to Ruby Link to this post

    Kate, I  was able to reproduce it using Telerik RadSchedular demos in IE8 compatibilty view. Please check if you have some solution to it. Thanks.
  11. Answer
    Kate
    Admin
    Kate avatar
    1898 posts

    Posted 31 Jan 2014 Link to this post

    Hello Ruby,

    I tested this demo in all modes of IE7 and IE8 browser and everything looks to be working as expected when I use a higher css class selector for the following styles:
    div.rsContentScrollArea {
           
    overflow-x: hidden !important;
            }

    Regards,
    Kate
    Telerik
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the UI for ASP.NET AJAX, subscribe to the blog feed now.
  12. Ruby
    Ruby avatar
    23 posts
    Member since:
    Mar 2012

    Posted 31 Jan 2014 Link to this post

    Thanks Kate. That worked for me. Thank you so so much .
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017