RadRotator not showing in IE11

5 posts, 0 answers
  1. Carl Sconnely
    Carl Sconnely avatar
    10 posts
    Member since:
    Mar 2010

    Posted 17 Oct 2013 Link to this post

    Today IE11 was released for Windows 8 and the radrotators I have in place on a few websites are not visible when being viewed in IE11.  I explored further and even looked at the Telerik rotator demo page (http://demos.telerik.com/aspnet-ajax/rotator/examples/overview/defaultcs.aspx) and your rotator example does not appear to be visible in IE11 as well.  Is there a workaround for this available?  Thanks!
  2. Slav
    Admin
    Slav avatar
    1356 posts

    Posted 18 Oct 2013 Link to this post

    Hi Carl,

    We are not aware of such problem with the RadRotator under IE11. I tried to reproduce it on my end, but to no avail as you can check in the linked screen capture. I would suggest examining it and letting me know if I am missing something.

    Please verify that you are using the latest version of IE11 and that the issue occurs in other instances of IE11 (it is not specific only for your machine). You can also check if something is blocking the requests for the images in the rotator, which prevents them from being displayed.

    Regards,
    Slav
    Telerik
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Carl Sconnely
    Carl Sconnely avatar
    10 posts
    Member since:
    Mar 2010

    Posted 18 Oct 2013 Link to this post

    Thank you very much for your response Slav.  Your demo is working on other PCs' at my office in IE11 on Windows 8 but I am running the same version of IE11 on Windows 7.  I will be sure to troubleshoot more to make sure it's not a computer specific issue.
  5. Carl Sconnely
    Carl Sconnely avatar
    10 posts
    Member since:
    Mar 2010

    Posted 21 Oct 2013 Link to this post

    I have performed more testing and have updated our site to use the most current Telerik .dlls but am still seeing issues on multiple computers running IE11 from Windows 7.   I have also had varying results while reviewing the Telerik demos for radrotator and radcombo box.  

    I have attached a few screenshots of my IE11 version and the results and what I am seeing.   In the ie11 console there is an error showing up "Unable to get property 'PageRequestManager' of undefined or null reference"   Ajax.js - Line: 105

    This is the same error I am receiving on our site when viewing it as well.  Any insight or help regarding this would be appreciated.  Thank you for your patience.



  6. Marin Bratanov
    Admin
    Marin Bratanov avatar
    3602 posts

    Posted 23 Oct 2013 Link to this post

    Hi Carl,

    The issue with general deployment and accessing sites with IE11 is caused by the fact the .NET does not recognize this browser, much like it didn't recognize IE10 when it was released last year.

    The PageRequestManager access error is caused by this problem. More information and link to a possible solution from Microsoft are available here: http://www.telerik.com/community/forums/aspnet-ajax/general-discussions/incorrectly-rendered-webpage-when-using-internet-explorer-11.aspx.

    Our entire site is in the compatibility mode list of Microsoft, so IE11 is likely to mask itself as IE10 and things should work fine for our demos. If your IE does not honor this list (e.g. because it is explicitly configured to), our demos may also break.

    Regards,
    Marin Bratanov
    Telerik
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017