RadRibbonTab (Rad Ribbon Tab) object not identified!

8 posts, 0 answers
  1. Azan
    Azan avatar
    1 posts
    Member since:
    Jul 2015

    Posted 24 Jul 2015 Link to this post

    I am testing an application developed in .Net/WPF and Rad Ribbon Tab/Object/Menu/Icons. I am using WPF Test Record and  Play feature, but unfortunately Test Studio is not identifying/picking up/recognizing RAD RIBBON TAB/MENU objects. Please help
  2. Cody
    Admin
    Cody avatar
    3360 posts

    Posted 28 Jul 2015 Link to this post

    Hi Azan,

    I am sorry you are running into this problem. I tried to reproduce it using our WPF Demo application. As demonstrated in the attached screen shot Test Studio is correctly recognizing the RadRibbonTab element. Do you have the same problem if you try doing the same thing using our WPF Demo application?

    If our demo app works as expected for you, this means the problem is specific to just your application. We'll need your help to reproduce the problem. Can you send us your WPF application, or a sample dummy application that demonstrates the problem?


    Regards,
    Cody
    Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
  3. Jakob
    Jakob avatar
    22 posts
    Member since:
    Mar 2014

    Posted 26 Oct 2015 in reply to Cody Link to this post

    Hi Cody and Azan

     

     If I understand Azan correctly, I'm experiencing the same or a similar issue with our WPF application. In the application we have a row of tabs at the top, which have become unresponsive, or rather Test Studio doesn't seem able to detect them. I've added a screenshot (sorry it's a bit cut off at the edges), taken at the moment when Test Studio gets stuck trying to locate the Radribbontab element. We were momentarily able to force recognition using the 'Edit Element' function, but that is also failing now.

    This seems to have started appearing after updating to the R3 2015 version of Test Studio. I've tried uninstalling and installing again, without success, and have now reverted back to Test Studio R2 2015 SP1, and the tests again appear to be stable and running fine. 

     

    Best regards,

    Jakob

  4. Ivaylo
    Admin
    Ivaylo avatar
    750 posts

    Posted 30 Oct 2015 Link to this post

    Hеllo Jakob,

    Without providing us with the application log we cannot determine what is causing the problem you are experiencing. Please clear the log, reproduce the issue and provide the log for further investigation.
    You can try re-recording the problematic step with the new version of Test Studio and see if it will execute.
    The best way to proceed in this scenario will be to provide us with the WPF application so we can reproduce this behavior and investigate.

    Thank you for your cooperation.

    Regards,
    Ivaylo
    Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
  5. Jakob
    Jakob avatar
    22 posts
    Member since:
    Mar 2014

    Posted 18 Nov 2015 in reply to Ivaylo Link to this post

    Hi Ivaylo

     

    Ok, so I ran one of my recorded tests on both versions 2015.2.723.0 and  2015.3.1112.0, and again the newest version fails in detecting the Rad ribbon tab objects. Actually it doesn't fail, I eventually have to stop the test manually, but it stays on that test step, looking for the object.

     

    I've attached the two log files, hope that helps you in investigating this. Also I've asked my developers to create an application mock-up and I'll send that to you as soon as I have it.

     

    Note: After many attempts I've noticed that occasionally the test does run, but this is in no way consistent. More often than not, it will fail, as per the attached log.

     

    Thanks

    Jakob

     

  6. Ivaylo
    Admin
    Ivaylo avatar
    750 posts

    Posted 23 Nov 2015 Link to this post

    Hello Jakob,

    The message in the log is way to generic and we cannot determine what is causing the failure:

    Outer Exception Type: System.IO.IOException
         Message: Pipe is broken.
         HRESULT: 0x800700E9 (Official ID (if app.) = 2147942633, Error Bit = FAILED, Facility = FACILITY_WIN32, Code = ERROR_PIPE_NOT_CONNECTED)
         Call Stack:
              at System.IO.Pipes.PipeStream.WinIOError(Int32 errorCode)
              at System.IO.Pipes.PipeStream.WaitForPipeDrain()
              at ArtOfTest.WebAii.Messaging.Process.PipeCommunication.WriteCommandToPipe(PipeCommand command, PipeStream pipe, Boolean waitForDrain)
              at Telerik.TestingFramework.WpfExtension.WpfCommunication._browserRemoteClient_BrowserRequest(Object sender, BrowserCommandEventArgs e)
              at ArtOfTest.WebAii.Messaging.Process.BrowserRemoteClient.ProcessBrowserRequest(Object sender, BrowserCommandEventArgs e)
              at ArtOfTest.WebAii.Messaging.Process.BrowserRemoteClient.ListenThreadEntry(Object objParam)


    It would be nice if we can reproduce the problem on our end and investigate further. Do you think you can provide your WPF application or a stripped down version which reproduces the behavior?

    Regards,
    Ivaylo
    Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
  7. Jakob
    Jakob avatar
    22 posts
    Member since:
    Mar 2014

    Posted 07 Dec 2015 in reply to Ivaylo Link to this post

    Hi Ivaylo

     

    Sorry about the late reply. I was recommended by one of your colleagues to create this as a support ticket. So when we're into our next post-release-quasi-calm-spell, I'll set about doing that. But also still chasing one of our developers to prepare a version of the application for you guys to reproduce the issue on your side, so will probably wait till I have that available.

     

    Regards,
    Jakob

     

  8. Ivaylo
    Admin
    Ivaylo avatar
    750 posts

    Posted 07 Dec 2015 Link to this post

    Hello Jakob,

    That sounds great. Please submit a ticket when you have a repro available and attach it there, we will be happy to reproduce and investigate further.

    Thank you for your cooperation.

    Regards,
    Ivaylo
    Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
Back to Top