RadPageView components positioning problem

16 posts, 0 answers
  1. Sandi Markon
    Sandi Markon avatar
    101 posts
    Member since:
    Jul 2012

    Posted 01 Feb 2013 Link to this post

    Positioning of components on RadPageView works different on different systems - see attached screenshots.

    I'm developing on Windows 7. 3 buttons have anchor set to right-bottom.

    On Server 2012 vertical positioning is bad.
    On Windows 8 both vertical and horizontal positioning are bad - you don't see any of 3 buttons.

    From time to time also RadPageView vertical size changes on itself to be bigger that the form itself and so you don't see whole RadPageView.
  2. Jack
    Admin
    Jack avatar
    2335 posts

    Posted 06 Feb 2013 Link to this post

    Hi Sandi Markon,

    The common thing that I see from these screenshots is that you are using custom DPI settings. In Q3 2012 we addressed most of the known issues related with custom DPI settings and our controls. However, WinForms is quite sensitive in this scenario and there may be issues when the form is created on a PC where custom DPI settings are used. You can try creating the same form with default DPI settings. If the issue still appears, please send us your application and we will investigate the case further.
     
    Greetings,
    Jack
    the Telerik team
    Q3'12 SP1 of RadControls for WinForms is out now. See what's new.
  3. UI for WinForms is Visual Studio 2017 Ready
  4. Sandi Markon
    Sandi Markon avatar
    101 posts
    Member since:
    Jul 2012

    Posted 11 Feb 2013 Link to this post

    I am not using custom DPI settings. Bigger sizes are achieved by setting font sizes for labels/buttons/... and other parameters for checkboxes/editboxes/...
    Another problem is than from time to time RadPageView size gets bigger than form size - see atached picture.
    Because this is larger application connected to DB, I'll try to reproduce this problem on a smaller sample...
  5. Sandi Markon
    Sandi Markon avatar
    101 posts
    Member since:
    Jul 2012

    Posted 12 Feb 2013 Link to this post

    Sample project on following link:
    https://www.dropbox.com/s/9itpjmzz4bxkmqv/RadPageViewProblem.zip

    I have also attached images of different component positioning on Windows 7 and Windows Server 2012.
  6. Sandi Markon
    Sandi Markon avatar
    101 posts
    Member since:
    Jul 2012

    Posted 13 Feb 2013 Link to this post

    Because there were problems with buttons on previous example, I have moved all buttons to the top and changed anchors to Top - Left.
    On this example (look at attached pictures), we have fixed inner pageview size and variable gridview.
    - on Windows 7 - everything OK
    - on Windows Server 2012 - to whatever size I resize form, part of pageview is not visible.
  7. Jack
    Admin
    Jack avatar
    2335 posts

    Posted 14 Feb 2013 Link to this post

    Hello Sandi,

    That is strange. I tested your application on Windows Server 2012 operating system and it looks OK. Is the screen resolution the same on both operating systems? Could you describe the display settings used on your Windows Server 2012 PC? 

    I am looking forward to your reply.

    All the best,
    Jack
    the Telerik team
    Q3'12 SP1 of RadControls for WinForms is out now. See what's new.
  8. Sandi Markon
    Sandi Markon avatar
    101 posts
    Member since:
    Jul 2012

    Posted 17 Feb 2013 Link to this post

    Hello.

    Resolution on Win 2012 was 1920x953 (because of remote access through RD tabs). If I connect through remote desktop with resolution 1920x1080, positioning is OK.
    Regarding this, the problem may be that our customer has resolution set to flipped portrait on Windows 8 machine. But component positioning should be same on all resolutions.

    Regards.
  9. Jack
    Admin
    Jack avatar
    2335 posts

    Posted 21 Feb 2013 Link to this post

    Hello Sandi,

    Thank you for these details. We will investigate the issue by using the specified parameters and I will write back when we have results.
     
    Regards,
    Jack
    the Telerik team
    Q3'12 SP1 of RadControls for WinForms is out now. See what's new.
  10. Sandi Markon
    Sandi Markon avatar
    101 posts
    Member since:
    Jul 2012

    Posted 21 Feb 2013 Link to this post

    Hello.

    Today I made another test project with settings I gave you last time, but now positioning works OK. Weird. I'll make some more tests myself.

    Regards,
    Mitja
  11. Sandi Markon
    Sandi Markon avatar
    101 posts
    Member since:
    Jul 2012

    Posted 25 Feb 2013 Link to this post

    Hello.

    Same problem with another old project upgraded to new components. 
    See attached files.

    First PC - display OK:
    Windows 7
    resolution 1680x1050

    Second PC - display not OK
    Windows 7
    resolution 1280x800

    Regards.
  12. Sandi Markon
    Sandi Markon avatar
    101 posts
    Member since:
    Jul 2012

    Posted 26 Feb 2013 Link to this post

    I have upgraded components to Q1 2013 and still the same problem...
  13. Jack
    Admin
    Jack avatar
    2335 posts

    Posted 26 Feb 2013 Link to this post

    Hello Sandi,

    Thank you for these details.

    We still have not found the reason for this issue. It looks like the issue is not platform specific since it appears on Windows 7 PCs. I will provide this information to our devs.

    If you have other questions, do not hesitate to ask.

    Kind regards,
    Jack
    the Telerik team
    Q3'12 SP1 of RadControls for WinForms is out now. See what's new.
  14. Sandi Markon
    Sandi Markon avatar
    101 posts
    Member since:
    Jul 2012

    Posted 19 Jun 2013 Link to this post

    Not sure if it's Visual studio or Telerik issue: https://copy.com/Tg1CXZ8HYHLQCpuL
  15. Jack
    Admin
    Jack avatar
    2335 posts

    Posted 24 Jun 2013 Link to this post

    Hello Sandi,

    At first sight the issue seems to be related with our controls. However, I will be able to give exact information after investigating the application. Please, could you send it to us. Thank you in advance.

    I am looking forward to your project.
     
    Regards,
    Jack
    Telerik
    RadChart for WinForms is obsolete. Now what?
  16. Sandi Markon
    Sandi Markon avatar
    101 posts
    Member since:
    Jul 2012

    Posted 15 Jul 2013 Link to this post

    About error from June, 19: If I change docking and reopen form, problem dissapears. I have changed dockings to Fill, so this is not an Issue anymore.
    About behaviour of radPageView on different systems: I have no time for testing at the moment.
  17. Paul
    Admin
    Paul avatar
    60 posts

    Posted 18 Jul 2013 Link to this post

    Hello Sandi,

    I am glad to hear that your issue has been solved. In future, If you find time and you are willing to assist us with this case, please try to isolate both cases in a sample project and get back to us with it so we can investigate the reasons for the issues and address them if possible. 

    Regards,
    Paul
    Telerik
    TRY TELERIK'S NEWEST PRODUCT - EQATEC APPLICATION ANALYTICS for WINFORMS.
    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
Back to Top
UI for WinForms is Visual Studio 2017 Ready