RadMenu not following ExpandDirection setting

2 posts, 0 answers
  1. Jonathan
    Jonathan avatar
    12 posts
    Member since:
    Apr 2013

    Posted 10 Oct 2013 Link to this post

    Hi

    I have a RadMenu that is not expanding in the down direction as set.  It is a horizontal menu.  The menu control is in the master page.

    Any ideas?  

    Thanks!
    < <div class="FullBanner" style="BACKGROUND: url(./images/grassBanner.png); FLOAT: left; WIDTH: 99%; HEIGHT: 75px">
                <a title="Organize"
                    href="http://organize.ohea.org">
                    <div style="WIDTH: 99%; HEIGHT: 75px"></div>
                </a>
            </div>
     
            <telerik:RadAjaxManager ID="RadAjaxManager1" runat="server">
     
                <AjaxSettings>
                    <telerik:AjaxSetting AjaxControlID="RadGrid1">
                        <UpdatedControls>
                            <telerik:AjaxUpdatedControl ControlID="RadGrid1" LoadingPanelID="RadAjaxLoadingPanel1"></telerik:AjaxUpdatedControl>
                        </UpdatedControls>
                    </telerik:AjaxSetting>
                </AjaxSettings>
            </telerik:RadAjaxManager>
     
            <telerik:RadScriptManager ID="RadScriptManager1" runat="server">
            </telerik:RadScriptManager>
     
            <telerik:RadAjaxLoadingPanel ID="RadAjaxLoadingPanel1" runat="server" Height="100%" Width="100%"
                Transparency="25">
            </telerik:RadAjaxLoadingPanel>
     
            
     
            <telerik:RadAjaxPanel ID="RadAjaxPanel1" runat="server" Width="100%" EnableAJAX="False">
                <telerik:RadFormDecorator ID="RadFormDecorator1" runat="server" DecoratedControls="All" Skin="Forest" />
               
                <telerik:RadMenu ID="menu" runat="server" Width="99%">
                    <Items>
                        <telerik:RadMenuItem runat="server" Text="Campaigns">
                            <Items>
                                <telerik:RadMenuItem runat="server" Text="Create New">
                                </telerik:RadMenuItem>
                                <telerik:RadMenuItem runat="server" Text="Current Campaign Home"  Value='<%#  String.Format("~/childCampaignHome.aspx?campaignID={0}", Request.Params["CampaignID"]) %>' NavigateUrl='<%#  String.Format("~/childCampaignHome.aspx?campaignID={0}", Request.Params["CampaignID"]) %>'>
                                </telerik:RadMenuItem>
                            </Items>
                        </telerik:RadMenuItem>
                        <telerik:RadMenuItem runat="server" Text="Employers">
                            <Items>
                                <telerik:RadMenuItem runat="server" Text="Add/Update/Delete"  Value='<%#  String.Format("~/childManageEmployer.aspx?campaignID={0}", Request.Params["CampaignID"]) %>' NavigateUrl='<%#  String.Format("~/childManageEmployer.aspx?campaignID={0}", Request.Params["CampaignID"]) %>'>
                                </telerik:RadMenuItem>
                            </Items>
                        </telerik:RadMenuItem>
                    </Items>
                    <DefaultGroupSettings ExpandDirection="Down" />
                </telerik:RadMenu>
                <hr width="99%" align="left" />
                <div>
                    <asp:ContentPlaceHolder ID="ContentPlaceHolder1" runat="server">
                    </asp:ContentPlaceHolder>
                </div>
            </telerik:RadAjaxPanel>
  2. Jonathan
    Jonathan avatar
    12 posts
    Member since:
    Apr 2013

    Posted 11 Oct 2013 Link to this post

    I believe this was a caching issue in the browser.  After rebooting, the menu started behaving.

    Please disregard, thanks!
  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top