RadMenu is not working on Safari

4 posts, 0 answers
  1. Sheeraz
    Sheeraz avatar
    27 posts
    Member since:
    Nov 2012

    Posted 07 Jan 2013 Link to this post

    Hi,

    I am using telerik controls since last one year and these control are compatible with IE, FireFox, Chrome but not working in Safari.
    I have tried to use menu control, button, combobox, grids but server side events are not working on Safari.
    I found some links which are saying that they got solution, I tried them but they are of no use. here are the links

    http://forums.asp.net/t/1733434.aspx/1

    http://www.codeproject.com/Tips/429169/ASP-NET-menu-control-issue-in-Chrome-and-Safari

    http://bettereducation.com.au/it/yaf_postsm2938_Problem-with-rendering-aspnet-menu-control-in-Chrome-and-Safari.aspx

    http://dotnetslackers.com/Community/blogs/kaushalparik/archive/2009/02/13/asp-menu-server-control-cross-browser-compatibility-safari-chrome.aspx

    http://dotnet-muthukrishnan.blogspot.com/2012/03/aspnet-menu-control-not-working-in.html

    solution mention in above links are not working. Please help me out in this regard and please provide some test project which having mentioned controls and is working on Safari. 

    Regards
    Sheeraz Raza
  2. Kate
    Admin
    Kate avatar
    1898 posts

    Posted 09 Jan 2013 Link to this post

    Hi Sheeraz,

    I tested our controls in the on-line demos but everything is working as expected in Safari browser. The server-side events fire as expected. Give it a try and let me know how it goes when you test our on-line demos?

    All the best,
    Kate
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Sheeraz
    Sheeraz avatar
    27 posts
    Member since:
    Nov 2012

    Posted 09 Jan 2013 Link to this post

    Hi Kate,

    Thanks for your response. I agree with you and I have already tested you live demos on safari and they are working perfectly fine. During my testing I also noticed that when I use Safari as my default browser and debug application using safari it works fine. But when I deploy my application and try to use the deployed one it would not work on safari. I have tried to use asp menu control and telerik menu control nothing work. I think its about configuration setting or something else as it works on safari in debug mode but not with deployed one. I think you might know this issue. Please help me in this regard.

    Thanks
    Sheeraz Raza
  5. Kate
    Admin
    Kate avatar
    1898 posts

    Posted 09 Jan 2013 Link to this post

    Hello Sheeraz,

    Deploying web site containing RadControls would require the same steps as if you would deploy any other web site. For some more information you can refer to the following help articles:
    As a side note I would suggest that you check if there are any errors on the page that might be causing the problematic behavior.

    Kind regards,
    Kate
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top