RadListControl seems to select the first item when a filter is applied

2 posts, 0 answers
  1. Brian
    Brian avatar
    1 posts
    Member since:
    Nov 2012

    Posted 09 Aug 2013 Link to this post

    Hi,

    Applying a filter to a radlistcontrol seems to select the first item as well as filtering the list, any ideas?

    Brian

  2. Dess
    Admin
    Dess avatar
    1609 posts

    Posted 14 Aug 2013 Link to this post

    Hello Brian,

    Thank you for contacting Telerik Support.

    After initial loading of the RadListControl (DataSource property is set to Customers data table) the first item in the collection is selected -> normal behaviour. In case of applying a filter, no selection is available if the previous selected item is available in the filtered collection. Otherwise, the selection remains. Please see the attached picture. This is normal behaviour of RadListControl. If you want to remove the selection every time a filter is applied you may set the SelectedIndex property of the control to -1. 

    Off topic, we kindly ask you to use just one support channel to contact us. Posting the same questions numerous times slows down our response time because we will need to review and address two or more tickets instead of one. Moreover threads are handled according to license and time of posting, so if it is an urgent problem, we suggest you use a support ticket, which would be handled before a forum thread.

    Thank you for your understanding.

    Regards,
    Desislava
    Telerik
    TRY TELERIK'S NEWEST PRODUCT - EQATEC APPLICATION ANALYTICS for WINFORMS.
    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
  3. UI for WinForms is Visual Studio 2017 Ready
Back to Top